Jitsi stun server failure on private network

I’m configuring the self-hosted latest version on a private network. please find the network diagram.

private IP: 172. X.X.X
public IP: 122. X.X.X

env configuration as follows.

Host join through a private network and Guests participate through the public internet.

Configuration 01;

DOCKER_HOST_ADDRESS=172.x.x.x

LOCAL_ADDRESS=172.x.x.x

Result: Both join the meeting. Video Streaming not working.

Configuration 02;

DOCKER_HOST_ADDRESS=122.x.x.x

LOCAL_ADDRESS=172.x.x.x

Result: Both join the meeting. Video Streaming not working.

Note: Configuration 02 is working when both host and guests join through the public internet.

Questions:

  1. can we config both public and private IPs?
  2. is there any other solution for configuring two private and public DNS?

You need a firewall rule which redirects “the local UDP/10000 traffic to the external IP” to the Jitsi host IP (172.x.x.x)

BTW the issue is not related with stun

Thank you for your quick response. there are two DNS resolvers for private and public zones.

public DNS resolves the public IP and private DNS resolve the private IP. But here I can add only private or public IP for DOCKER_HOST_ADDRESS.

here is the output when configuring the private IP for DOCKER_HOST_ADDRESS and connecting from the public Internet.

I’m not familiar to Dockerized setup but according to the docs, you should set the private IP (172.x.x.x) as DOCKER_HOST_ADDRESS. Jitsi will find its external IP using an external STUN service.

Is your server behind a router (NAT), right?

1 Like

sure, I will try this.

Yes

I will resolve this issue by adding the following configurations.

change env as follow.
DOCKER_HOST_ADDRESS=
LOCAL_ADDRESS=

change jibri.conf file as follows.

1 Like

Notes to myself

# don't disable STUN in sip-communicator.properties
hocon -f /etc/jitsi/videobridge/jvb.conf set \
  ice4j.harvest.mapping.stun.enabled true

# first local pair
hocon -f /etc/jitsi/videobridge/jvb.conf set \
  ice4j.harvest.mapping.static-mappings.0.local-address 172.22.22.14
hocon -f /etc/jitsi/videobridge/jvb.conf set \
  ice4j.harvest.mapping.static-mappings.0.public-address 192.168.1.56

# second local pair
hocon -f /etc/jitsi/videobridge/jvb.conf set \
  ice4j.harvest.mapping.static-mappings.1.local-address 172.22.22.14
hocon -f /etc/jitsi/videobridge/jvb.conf set \
  ice4j.harvest.mapping.static-mappings.1.public-address 10.1.1.56

systemctl restart jitsi-videobridge2.service
1 Like