Jitsi stopped working about a week ago

Both myself and a friend host our own jitsi server on ubuntu 18. Both our servers stopped working about a week ago. We can connect but the we cannot see each other. The behavior is the same on both our servers. Is there something changed that I need to be aware of? We’ve tested on several browsers, window and McOS.

Any and all suggestions appreciated.

Welcome to the forum.

This is almost certainly due to the move to Unified Plan by Chrome. You need to upgrade your Jitsi server to the latest version (or any of the 3 prior versions).

Tried a fresh install on the ubuntu 20 and used latest version of Jitsi. I got the same result. :frowning:

Which “several browsers” did you test with?

You can confirm whether it’s the Plan-B deprecation by looking in the browser console for red error messages telling you to move to Unified Plan. If you have those errors, then you’re still running an old version of the frontend.

I tried Chrome, Firefox, and Safari

In that case it’s not the Plan-B deprecation. If your backend and frontend are both self-hosted, you’ll need to figure out what changed on your setup.

Oddly enough I restored my Jitsi from a 3 week old backup. Same issue. I can start a meeting and see myself but when another joins we can’t see each other. Bizarre

Maybe something changed in the network configuration of the server or client?

I was thinking the same thing. It seemed to happen after running a ubuntu update. But Not sure where to check or what to check for. I don’t mind doing a fresh install but a fresh install doesn’t work. Do you have a good guide for installing on ubuntu?

Check your firewall. Make sure all required ports are open and accessible. Check port 10000/UDP especially; make sure it’s open and properly forwarded if behind a NAT.

I have double checked the firewall settings and it’s all good there.

What are the errors you see in the js console?

I’m doing a fresh install on Ubuntu now… Gonna see how that goes. I appreciate your advice! Thanks