Jitsi site can’t be reached after Apache install

Hi, I wanted to install apache to run some PHP scripts on the same server jitsi is installed, but now jitsi won’t load at all.

I removed apache, but jitsi still won’t load. I’ve also tried restarting all the modules -
/etc/init.d/jicofo restart
/etc/init.d/jitsi-videobridge restart
/etc/init.d/prosody restart

Host is pingable and firewall is disabled, what am I missing?

In case someone has the same issue, make sure to delete ALL instances of apache2 -

sudo apt-get remove --purge apache2 apache2-utils
sudo rm -rf /etc/apache2

Ping your IP directly to see if apache or nginx install / welcome page is showing. If nginx, you’re good to go to next step. You may have to kill ports 443/80 (netstat -tulpn, see if the ports are attached to nginx or apache) Make sure you have jitsi-meet in your nginx modules-enabled:

vi /etc/nginx/modules-enabled/60-jitsi-meet.conf

paste the following in the above file:

 stream {
 upstream web {
     server 127.0.0.1:4444;
 }
 upstream turn {
     server 127.0.0.1:4445;
 }
 # since 1.13.10
 map $ssl_preread_alpn_protocols $upstream {
     "h2"            web;
     "http/1.1"      web;
     "h2,http/1.1"   web;
     default         turn;
 }
 
 server {
     listen 443;
 
     # since 1.11.5
     ssl_preread on;
     proxy_pass $upstream;
 
     # Increase buffer to serve video
     proxy_buffer_size 10m;
 }
 }

and finally, chmod 777

chmod 777 /etc/nginx/modules-enabled/60-jitsi-meet.conf
service nginx restart

1 Like