Jitsi server on different port, main web server log 404 error GET /colibri-ws

Hi,
I have a main webserver on port 80. I setup Jitsi following some instructions on port 80/443 (and other ports). It works. I then edited the config file in Jitsi and nginx to change the ssl port for Jitsi to 444. That also works. I can connect to my Jitsi server on port 444 from the internet.
In my main webserver (apache) logs I am getting a lot of these errors:
GET /colibri-ws/default-id/c9fdfb71f7855f4/bc9fe39b?pwd=7pliom9s5jguj4qjpun4tu3ur HTTP/1.1

From a search I cannot see how to fix this. Also I read that someone says after 3 to 4 clients connect the video quality starts to degrade.

I did fine something someone said on here about ProxyPass config in the apache httpd.conf but I’m not sure what to set.
ProxyPassMatch ^/colibri-ws/default-id ws://localhost:9090
ProxyPassReverse ^/colibri-ws/default-id ws://localhost:9090
Has anyone any ideas?
Thank you
Paul

Checkout here jitsi-meet/jitsi-meet.example-apache at master · jitsi/jitsi-meet · GitHub

Hi,
thanks for the tip. I have tried to replicate what I think should be the right setting but now I get a different error code 500

In my apache ssl.conf I added
ProxyPassMatch ^/colibri-ws/default-id ws://myserver.com:444

Does that look right?
thanks
Paul

Check prosody logs for errors, or apache logs for errors.

Also you need to enable this module in apache proxy_wstunnel

Do I need colibri? Can I just ignore these errors?

You can, dominant speaker detection, stats from remote participant will be missing and the resolution will be to lowest possible.

Heh damencho, thank you for you time.

I can’t find a log file associated with prosody. I’ve looked in /var/log and /etc/prosody

I’ve done a ‘find / -name prosody’ and that doesn’t show up a log

So the apache error log error is too long and cuts off

No protocol handler was valid for the URL /colibri-ws/default-id/c7a4013e42ee1f7f/bbc361fd (scheme 'ws'). If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.

I googled the error and a resolution for that in the error.log was a missing trailing slash, updated below.

No more errors in my httpd-error.log but I still have these in httpd-access.log

GET /colibri-ws/default-id/fb7f70f86730e6b8/6704ef37?pwd=8a3h4lb7n2jdiaifgm2vd7hbi HTTP/1.1" 200

Actually log code 200 is “OK”! so I think it is okay now :slight_smile:

Thank you for your help.