Jitsi SDK Android error when installing in Expo projects

We have a React native app which has been ejected from Expo using expo eject.
We were able to integrate Jitsi for iOS without any issues, however: while trying to install Jitsi dependencies on this project for android - we get the following error:

> Task :expo-dev-launcher:compileDebugKotlin
Compilation with Kotlin compile daemon was not successful
java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
        java.rmi.UnmarshalException: error unmarshalling arguments; nested exception is:
        java.io.InvalidClassException: org.jetbrains.kotlin.incremental.IncrementalModuleInfo; local class incompatible: stream classdesc serialVersionUID = 1, local class serialVersionUID = 0

But, while following the same steps on a bare react native app (which has not been initialised with expo), the error doesn’t happen.
Is Jitsi not compatible with expo projects? Or are there any additional steps to be followed for expo projects?

We don’t use Expo, so I’m not sure if we have problems there or not…