Jitsi Scalable

Hi @rowansc1,

This is a new bug, I fixed it in the installer repo.
Thank you for reporting this issue.

You can rerun the installer to fix the issue.

Ah right. What should I do to the existing install? Or should I just clean install?

Thanks for fixing that bug @emrah.

You can rerun the installer again. It will recreate the containers using new config.

Hiya @emrah,

Awesome thanks. Just to confirm, run the installer for all JMS, JVB and Jibri nodes?

yes

Thank you

I am assuming @emrah that I’ll need to enable the

#export REINSTALL_JITSI_IF_EXISTS=true

Line in the config file since it already exists

That is right, please uncomment this line.

It is disabled by default to prevent accidental overwriting of an already customized Jitsi.

Yeah fair enough.

Thank you again for all of your help! I really appreciate it. Your installer scripts are amazing! Keep up the good work.

1 Like

Hiya @emrah,

Sorry for another message.

I’m not sure but this could be a bug. Whenever I start to record a meeting, it says “Preparing to record meeting” and never gets to “recording has started”. So, when I go to stop the recording, it says “Recording has stopped” but no file is created on the Jibri node.

I tried on my newly installed Jitsi but I cannot create the same issue.

  • which folder do you check for MP4 file?
  • do you have jibri instances on JMS too?
  • can you share Jibri logs?

I firstly run lxc-attach eb-jibri-1 then ls -alh /usr/local/eb/recordings/* to check if recordings are there (On the jibri node).

No, I only have one Jibri node as per your guide.

Of course:
log.0.txt - 2022-08-07 08:00:56.833 INFO: [1] MainKt.handleCommandLineArgs#186: Jibri run wi - Pastebin.com

Does Jibri node resolve the Jitsi FQDN? There is some DNS issues in logs.

Hiya @emrah,

No, the main FQDN resolves to the JMS node and the Jibri FQDN resolves to the Jibri node.

What is the output for the following command in eb-jibri-1 on Jibri node?

host JITSI_FQDN
Host JITSI_FQDN not found: 3(NXDOMAIN)

Assuming you changed JITSI_FQDN with the actual FQDN,

Does it resolv any other domain? e.g. meet.jit.si

I haven’t edited anything with the Jibri node after running add-jibri-node on JMS.

If you don’t mind giving SSH access to me, I can check it.

Some additional thoughts:

Are JMS and Jibri node on the same local network?

If so, can jibri access the JMS web using its FQDN?

Does jibri resolv JMS IP using its FQDN? If yes, which IP? internal or external…?