Jitsi Rooms list issue

mod_muc_size.txt (9.2 KB)
Hi,

There might be the same question already on the forum, but posting it again.
We are facing an issue getting rooms list from the Jitsi server.
What we did we install jitsi meet on the digital ocean marketplace.
Now we want to get all rooms created on the server.
I did changes in mod_muc_size.lua file under prosody plugin, then do config change in the Nginx configuration file.
But we are getting a 502 gateway error.
The URL that I am hitting over the server is: domainname.com/rooms
I have attached mod_muc_size.lua file in the attachment. I renamed it as a txt file because I was not able to upload the .lua file here.

we configure rooms in Lua file and Nginx config file.

Could you guys please help us we are stuck here for many days?

did you check prosody logs ?

yes i check. there is no error on logs, i check prosody logs, jicofo logs as well.
in ngniix logs i saw error while hit url is that:
no resolver defined to resolve DOMAIN NAME client: IP ADDRESS, server: DOMAIN NAME, request: “GET /rooms HTTP/1.1”, host:

I’d say that it points to a nginx configuration error :slight_smile: . Possibly you used a proxy_pass statement with a host name instead of localhost.

yes, if i use localhost it say smae error:
no resolver defined to resolve LOCALHOST client: IP ADDRESS, server: DOMAIN NAME, request: “GET /rooms HTTP/1.1”, host:

I tried with IP 127.0.0.1 as well
I will share my ngnix config

I added these lines on ngnix file:

 location = /rooms {
        proxy_pass DOMAIN NAME:5280/room-list?$args&domain=DOMAIN NAME;
        proxy_set_header X-Forwarded-For $remote_addr;
        proxy_set_header Host DOMAIN NAME;
        add_header Content-Type "application/json; charset=UTF-8";
        #add_header 'Access-Control-Allow-Origin' '*';
add_header 'Access-Control-Allow-Methods' 'GET, POST, OPTIONS';
add_header 'Access-Control-Expose-Headers' 'Content-Length,Content-Range';
    }

Is there some other config that we need to do to make the API work?

So it should work when i hit url:
DOMAINNAME/rooms

but it returns 502

uh, that don’t quite seem possible. Did you restart nginx ?

yes i did try.

oh well, what gives
ping DOMAIN NAME
when you run it on your server ?

Here you normally set 127.0.0.1