Jitsi rooms do not connect / participants remain in separate rooms

I am new to Jitsi and currently trying to set up my own Jitsi server (basically to substitute Nextcloud Talk). I followed the instructions for Ubuntu 20.04 under „https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-quickstart/“. I use certificates from Let‘s encrypt. The installation is behind an Apache webserver.
I can reach my Jitsi domain via the webbrowser (firefox) without problem. But then, the problems start:

  • I can create a room, but when I try to access the room from another machine, the two rooms (although the name is exactly identical) remain separate (I cannot see any other participants in the participants list, let alone getting a video connection).
  • When I connect from a mobile phone (Android) via the browser, the same occurs.
  • When I use the Jitsi app from the Android mobile, the app cannot connect to the room. It just tries to connect endlessly (server/domain is set correctly).

The needed firewall ports (10000/UDP, 443/TCP, 4443/TCP, 3478/UDP, 5349/TCP, 80/TCP) are open and forward via the router (NAT). Apparently, the webserver also works ok.

I was absolutely not able to find any mistake, going through the installation instruction again and again. Then, I purged Jitsi and all components and did a fresh installation (again following the above mentioned procedure, but this time without the prosody package, as I only wanted to focus on Jitsi). Same problems! The logfiles do not ring a bell with me. The only thing I get is out of jicofo.log:

Jicofo 2022-07-11 08:56:05.617 SEVERE: [30] JvbDoctor$AbstractHealthCheckTask.run#277: Error when doing health-check on: Bridge[jid=jvbbrewery@internal.auth.meet.famili>
java.lang.NullPointerException
at java.base/java.util.Objects.requireNonNull(Objects.java:221)
at org.jitsi.jicofo.bridge.JvbDoctor.getConnection(JvbDoctor.java:77)
at org.jitsi.jicofo.bridge.JvbDoctor$HealthCheckTask.doHealthCheck(JvbDoctor.java:162)
at org.jitsi.jicofo.bridge.JvbDoctor$AbstractHealthCheckTask.run(JvbDoctor.java:266)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.runAndReset(FutureTask.java:305)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:305)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:829)

I am totally lost and do not know where to efficiently start further debugging. Do you have any idea where the issue could be?

Make sure the full chain of certificates are installed.

Open the js console in the browser. Any errors there?

Are there any errors in jvb or jicofo logs on startup?

Thanks a lot. Issue solved. Your last sentence (“errors on startup”) actually helped me a lot :wink: As I was lost in all the logging, I restarted the services with a new logfile.
There, I actually saw that the videobridge binds to port 8888, which I was not aware of. On this very port, an internal webserver was running. After changing the latter to a different port everything worked fine. Maybe it is worth stating in the installation manual, which ports are needed internally.