Jitsi Recording is not working on custom port

Hello,

I am new here and I successfully installed and configured Jitsi Meet and Jitsi Recording on my end using the default port 443. However, there’s already a server that is using 443 which is also self hosted on the Internet. So I decided to use a custom port.

After I changed ports, all functionality is working except for the recording/livestreaming.

What I did:

a. Changed the default port 443 to a custom port 5555 to /etc/nginx/sites-enabled/<my_fqdn>.conf

image

b. Edit bosh URL and add custom port 5555 to /etc/jitsi/meet/<my_fqdn>-config.js

// BOSH URL. FIXME: use XEP-0156 to discover it.
    bosh: '//<my_fqdn>:5555/http-bind',

c. Restart nginx, jitsi-videobridge2, jicofo, and prosody services.

Checking errors:

Jicofo.log

Jicofo 2021-04-26 09:50:48.317 INFO: [64] JibriSession.handleJibriStatusUpdate#6
29: Got Jibri status update: Jibri jibribrewery@internal.auth.uc-srv.zcstestarmy
ph.ml/jibri-instance-1 has status pending and failure reason null, current Jibri
jid is jibribrewery@internal.auth.uc-srv.zcstestarmyph.ml/jibri-instance-1
Jicofo 2021-04-26 09:50:48.317 INFO: [64] JibriSession.handleJibriStatusUpdate#6
76: Successfully resumed session with another Jibri
Jicofo 2021-04-26 09:50:48.481 INFO: [65] JibriSession.processJibriIqFromJibri#458: Updating status from JIBRI: for frontprogressespackagereportedly@conference.uc-srv.zcstestarmyph.ml
Jicofo 2021-04-26 09:50:48.481 INFO: [65] JibriSession.handleJibriStatusUpdate#629: Got Jibri status update: Jibri jibribrewery@internal.auth.uc-srv.zcstestarmyph.ml/jibri-instance-1 has status off and failure reason error, current Jibri jid is jibribrewery@internal.auth.uc-srv.zcstestarmyph.ml/jibri-instance-1

Thank you very much.

1 Like

There is no such option at the moment. You need this to be merged Adding XMPP Port option to config file by kpeiruza · Pull Request #398 · jitsi/jibri · GitHub and then to use that new jibri version.

1 Like

Thank you for your fast response @damencho . To clarify, if we apply the said fix, can this still be applicable to revert to the default 443 port?

1 Like

Actually that is for another port, well you need something similar, I guess

1 Like

Please see [Jibri] Recording on a custom port with the stable version of Jitsi-meet.