Jitsi recording fails immediately with Jibri

I’m having a problem after configuring Jibri. I can’t record or stream because both give me an error as soon as I click on the option. Is there any new solution since then.

You need to share your jibri logs to help identify the problem.

log.0.txt (1.6 MB)
here is the jibri log file (log.0.txt)

What java version are you running? Is port 5222 open and accessible on the Jitsi server?
Share your jibri.conf.

2023-01-02 21:06:55.477 WARNING: [31] [hostname=visio.backbone-corp.com id=visio.backbone-corp.com] MucClient.lambda$getConnectAndLoginCallable$9#631: Error connecting:
org.jivesoftware.smack.SmackException$EndpointConnectionException: The following addresses failed: 'RFC 6120 A/AAAA Endpoint + [visio.backbone-corp.com:5222] (visio.backbone-corp.com/132.226.119.26:5222)' failed because: java.net.SocketTimeoutException: connect timed out

Jibri is not able to connect to prosody on 132.226.119.26:5222.
Maybe firewall?

I’m using Java version 11 and I checked, the port is not accessible on the server. I’ll activate it and give you a feedback

I authorized port 5222/tcp on the server and the error given by jitsi has changed now I get ‘‘all recorder are busy’’
image
when I search the community forum I can’t find what is causing the error, I am asked to put jicofo and jibri to their unstable version but I don’t know how to do it despite the fact that I am asking on this forum

log.0.txt (10.3 KB)

There is a problem related with Chrome now. Do you have already installed desktop on jibri server?

it seems that chrome has crashed. i see an error that says chromedriver is assuming that chrome has crashed.and i don’t know how to install Desktop on jibri server

jibri installs its own desktop but if there is another desktop environment before the Jibri installation, this will cause problems.

how do i locate if there is another desktop environment?

You may check the process list as root

ps auxww

process_list.txt (25.5 KB)
here is the list of process


i think i have two Desktop environment, Gnome and JWM,

Yep, this is the problem. You should install jibri in a server which has no desktop environment. Otherwise jibri cannot activate its own desktop.

So I have to uninstall both environments and then reinstall Jibri basically?

Theoretically that is right but removing an already installed GNOME doesn’t always work correctly.

:joy: :joy: is there an optimal solution then? I feel like it’s a loop, removing the desktop environments might not work but jibri won’t work without its desktop environment

You should wipe that server clean and start all over without a desktop environment. That’s the smoothest option.

1 Like

when I go to the /usr/share/xsession folder, I notice 3 entries, image Jibri needs to work with icewm-session because when I tried to uninstall icewm Jibri automatically uninstalled, but I don’t know if it’s possible to remove the other desktop environment to just leave the one Jibri uses, so remove Gnome.