Jitsi prosody compatibility with ubuntu 14

Hi, the version of jitsi is compatible with ubuntu 14? because when i upgraded the version of jitsi from 7001 to 8044-1 i have a issues in prosody container in ubuntu 14, but in Ubuntu 22 is working properly with the same configuration.

Welcome to the forum.

Ubuntu 14??? That’s really, reeeeaally old. Even Ubuntu 18 is becoming tough to support now. Upgrade to at least Ubuntu 20.04 to save yourself an avalanche of headaches.


There is a reason? kernel issues … because i don’t see it in the log like deprecated dependencies or comptability issues with ubuntu 14, even in jitsi github site didn’t mention it, thank you for the reply.

From the documentation: Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet

Ubuntu 20.04 (Focal Fossa) or newer (Ubuntu 18.04 can be used, but Prosody version must be updated to 0.11+ before installation)

We don’t have the resources or inclination to support such old versions, sorry.

Hi, it works in ubuntu 14, we must upgrade the kernel to 4 (of Ubuntu 16), we don’t have to upgrade the os.
we should use this command apt-get update && apt-get install linux-generic-lts-xenial after that we restart our system.

I suspect you will have other issues though. Hopefully, I’m wrong.

of course in preference using latest distributions, but in my case upgrading the OS is not a option.

Hi saghul,

I am facing an issue while installing jitsi meet in 18.04. and as you mentioned for ubuntu 18.04, prosody version must be 11+ so mine is 1. but still I am facing issues for unmet dependencies for lua packets. so can you please guide me how can I install jitsi meet on my 18.04 system.

I am following this link:
Deps on lua-inspect breaks installation on Ubuntu 18 - #15 by suraj.

Ubuntu 18.04 will reach the end of life in 4 months. Why don’t you switch to a newer distro?

actually server setup of my application is on 18.04 and other things except jitsi are running fine and it is very large setup. so to migrate whole setup to Ubuntu 22 is very difficult. that is why I want to run jitsi meet on Ubuntu 18.04.

Describe your problem. If you have missing dependencies from a newer distro version, you can always add the newer version repo to apt sources, while pinning the whole installation to the older version you prefer and then explicitly add/upgrade the packages you need. If you know your apt, you can fix any version issues - Prosody is not a critical package and it will hardly break anything when you mix 18.04 with latest Prosody.

To guide you in more details, please describe your problem - or even better, please use another thread, as this one is for Ubuntu 14 and we may mislead future readers.

Hi Yasen

I want to ask if I import bundle files in libs folder (bundle “.min” files) of running project which I created on 16 GB RAM system build it on Ubuntu 22 and then replace it with another project running on 8GB RAM system and Ubuntu 18.04 with same config files then other features are running fine but noise suppression and local recording features are not showing in the more option menu.

so to run these features where should I focus what are the responsible factors which may affect these two features.

output of — $ dpkg -l | grep jitsi :
ii jitsi-meet-prosody 1.0.4466-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-tokens 1.0.4466-1 all Prosody token authentication plugin for Jitsi Meet
ii jitsi-videobridge2 2.1-607-g153f7e4e-1 all WebRTC compatible Selective Forwarding Unit (SFU)

I’m sorry I can’t help with that. You mentioned apt dependencies problems with prosody, but mixing versions of Jitsi minified javascript code files is something very different that I’m not expert into. Please open a separate thread for this, hopefully someone may help.

Okay, @yasen. Thanks for your response.