Jitsi prefix room name

Hi!

Due to the possibility of accidentally creating a room with the same name, is there a function or module to add a prefix to the room name.

Something similar to jitsi.company.com/1577$RoomName
or
jitsi.company.com/1356/$RoomName

Thanks for any help!!

I have a solution for this but it works only if meetings are organized through eparto.net.

There is an option as “enable unpredictable room name generator” while creating a meeting room. If this option is checked, the room name is generated like “NAME-random-uuid”.

If properly set up, jitsi deployments should support subdomains, i.e. meet.youdomain/somethingRandom/nicerRoomName

For example: Jitsi Meet

Hi!
It’s weird but it doesn’t work for me :frowning:

On meet.jit.si or your own deployment? What errors do you see?

I’m afraid I’m currently away from computer so can’t offer a lot of help, but if you describe the problem you have with it and what errors you see someone might be able to help.

All rooms are created without prefixes, something like this:

meet.jit.si/roomName and this causes concern when another person creates the same room.

I don’t see any errors in the logs, docker installation.

Who creates the room? Do you mean the landing page?

Does it work if you manually type on a room name with prefix?

Shawn, nope, even if I create the room manually - the prefix is ​​missing.

Type “test room” - create meeting → without prefix.

On meet.jit.si - i dont see prefix after creating room. Link looks like this - meet.jit.si/test

You can’t create rooms with prefix on the landing page (unless you modify the code I guess), but you can still generate it using other means e.g. from your own app or just manually in the address bar.

This works as expected, yes? Jitsi Meet

Yep! Works fine!

But how implement this changes to self-hosted docker installation?

https://meet.jit.si/d9e736fa6/NiceRoomName ?

I’m afraid I’m not familiar with the docker setup. What happens when you try that on your own deployment?

For docker you need to explicitly enable this: ENABLE_SUBDOMAINS=true
@saghul maybe we should enable that by default now, wdyt?

1 Like

Hi damencho!

I’ve enabled, but nothing happens.

Maybe I’m doing something wrong?

  1. Change .env
  2. rm -rf $CONFIG child items folder
  3. docker-compose up -d

This enables tenants so you will be able to have meeting links as https://domain.com/tenant/roomname.
Nothing more.

Yes, I understood this, but I do not have an intermediate location with a room. After creating an appointment, I get a direct link jitsi.company.com/roomName.

sorry, looks like you misunderstood me. I need to create rooms with a prefix in order to be able to create 2 identical appointments with the same name.

one docker instance, two rooms with the same name: room1 - room1, but absolutely different. The second answer in this thread solves this problem, but is it possible to implement this with standard jitsi tools?

Give an example of the 2 meeting links with the prefix as you’d like them.

Ok, for example i create 2 rooms with name superRoom on the same server:

  1. superRoom
  2. superRoom

Link looks like as jitsi.company.com/superRoom, but rooms are different.

The link must be generated from random characters or numbers regardless of the room name on the landing page, so I want to see if I can generate some kind of prefix before the room name.

That is, if these are two different rooms and link to them is different - only just the same name

jitsi.company.com/randomCharacters_ROOMNAME

This will solve 2 problems at once:

  1. Random entry of an extra guest
  2. Different rooms with the same name and unique link for each

You can do the random generation in your code?
And when opening the room set the correct name using the subject.
Or use the iframe API: IFrame API | Jitsi Meet

I prepared a quick video.

Two users create meeting rooms on the same server using the same name but they join two different rooms.