Jitsi on Debian 10 fails

hi all,
when I try to install in Debian 10 (4.19.0-8-amd64 #1 SMP Debian 4.19.98-1+deb10u1 (2020-04-27) x86_64)
I face an error as

root@webvk:~# sudo apt-get -y install jitsi-meet
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
jitsi-meet : PreDepends: jitsi-videobridge2 (= 2.1-197-g38256192-1) but it is not going to be installed
Depends: jicofo (= 1.0-567-1) but it is not going to be installed
Depends: jitsi-meet-prosody (= 1.0.4074-1) but it is not going to be installed
Recommends: jitsi-meet-turnserver (= 1.0.4074-1) but it is not going to be installed or
apache2 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I searched on the web but the solutions didnt fix my error.

1 Like

Do you have any webserver installed?

hi all,
it was arising from lack of repository. buster main, buster/updates, buster-updates, buster-backports are added and now working.

thank you.