JITSI on AWS configured & installed but not opening


#1

Hi All,

I have created an AWS instance and assigned an elastic IP to it. I then installed JITSI server on the instance and followed all steps & also got lets encrypt configured & SSL enabled - no errors during the process. However, when I go to jitsi.mydomain.com (entered the same for fqdn when setting up JITSI) - the default jitsi meet page is not loading. I have checked that JVB service is running (through systemctl).

jitsi.mydomain.com DNS A record is configured through my DNS provider’s console.

What am I missing? I have also enabled firewall rules on aws for HTTP HTTPS, 4443 and opened ports 10000-20000 UDP through AWS console.

Please help or suggest any ideas to check.

Regards,
Bruce V.


#2

try this: https://github.com/jitsi/jitsi-videobridge/blob/master/doc/tcp.md#orgice4jiceharvestnat_harvester_local_address

Set the value of NAT_HARVESTER_LOCAL_ADDRESS to your private EC2 Ip-address and the value of NAT_HARVESTER_PUBLIC_ADDRESS – to your public one.

Use them in the file /etc/jitsi/videobridge/sip-communicator.properties
And then restart jitsi-videobridge


#3

Those two values are not already there in the file - should I just add them? The other values in that file have a sort of java package name to it - What would be the exact value of the parameter key for those two params?

I added the following two values and restarted jvb… still doesnt work.

org.jitsi.videobridge.NAT_HARVESTER_LOCAL_ADDRESS=my private ip
org.jitsi.videobridge.NAT_HARVESTER_PUBLIC_ADDRESS=my public ip