Jitsi on a subdomain on a vps with a record

Hello,

with my usual webhoster i couldnt install jitsi so i got a vps elsewhere and did an a record to the subdomain. I installed Jitsi with the Quickinstall Documentation but i can’t see and hear any other participants because of a black screen. If the other participants deactivates his or her camera there is the grey screen. The chat works fine. We tried with different browsers and with the app. Is there something i need to do different when i install jitsi on a subdomain with an a record to the vps?

Errors i get with the console:
2020-04-09T09:27:51.478Z [features/base/tracks] <E/</<>: Failed to create local tracks

Array [ “audio”, “video” ]

Object { gum: {…}, name: “gum.not_found”, message: “Requested device(s) was/were not found: audio, video”, stack: “a@my domain/libs/lib-jitsi-meet.min.js?v=3969:1:120043\nvalue/</<@my domain/libs/lib-jitsi-meet.min.js?v=3969:1:98340\n” }

Logger.js:154:22

2020-04-09T09:27:51.010Z [features/analytics] <te/<>: Error: “No analytics handlers created!”
te functions.js:100

And withsomeone joining:
2020-04-09T09:29:49.679Z [JitsiMeetJS.js] : UnhandledError: null Script: null Line: null Column: null StackTrace: Error: “This client does not support P2P connections”
_rejectIncomingCall JitsiConference.js:1966
_onIncomingCallP2P JitsiConference.js:1799
onIncomingCall JitsiConference.js:1814
emit events.js:146
value strophe.jingle.js:165
run strophe.umd.js:1875
_dataRecv strophe.umd.js:3157
forEachChild strophe.umd.js:830
_dataRecv strophe.umd.js:3146
_onRequestStateChange strophe.umd.js:5012

2020-04-09T09:29:58.496Z [modules/RTC/BridgeChannel.js] : Bridge Channel send: no opened channel.

Are you opening through http or https link? webrtc does not work under http.

Opening with https. I am sorry i had to delete because of the 2 Links rule.