Jitsi octo setup not working - octo_enabled false

Hi
I am attempting to setup octo but I am getting octo enabled is false
The setup I am trying it with is JVB/NGINX/PROSODY/JICOFO/JMS on server 1, and JVB on server 2
Server 1 and 2 are not in the same data center

I am trying with SplitBridgeSelectionStrategy strategy to force users into the different bridges

Below are configuration files, component versions and extract of the jvb.log and jicofo.log

Any help is appreciated

Jitsimeet config

deploymentInfo: {

    region: "region1",
      userRegion: "region1"
},

testing: {

        octo: {
            probability: 1
    }

}

Nginx config

location ~ ^/colibri-ws/jitsimeet/(.*) {
proxy_pass http://127.0.0.1::9090/colibri-ws/jitsimeet/$1$is_args$args;
proxy_http_version 1.1;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection “upgrade”;
tcp_nodelay on;
}

location ~ ^/colibri-ws/bridge3/(.*) {
    proxy_pass http://<Public IP>:9090/colibri-ws/bridge3/$1$is_args$args;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
    tcp_nodelay on;
}

JVB sip-communicator.properties.octo on server 1

Additional values for octo

org.jitsi.videobridge.octo.BIND_ADDRESS=127.0.0.1
org.jitsi.videobridge.octo.PUBLIC_ADDRESS=
org.jitsi.videobridge.octo.BIND_PORT=4096
org.jitsi.videobridge.REGION=region1

JVB sip-communicator.properties.octo on server 2
Additional values for octo

org.jitsi.videobridge.octo.BIND_ADDRESS=127.0.0.1
org.jitsi.videobridge.octo.PUBLIC_ADDRESS=
org.jitsi.videobridge.octo.BIND_PORT=4096
org.jitsi.videobridge.REGION=region1

Jicofo sip-communicator.properties

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.<my_domain>
org.jitsi.jicofo.auth.URL=XMPP:jms1.univy.io
org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN=true
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.<my_domain>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1

org.jitsi.jicofo.BridgeSelector.BRIDGE_SELECTION_STRATEGY=SplitBridgeSelectionStrategy

jicofo.conf

jicofo {
octo {
enabled = true
}
}

Version information

Prosody Version 11.7
ii jitsi-meet 2.0.5142-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4466-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-tokens 1.0.4466-1 all Prosody token authentication plugin for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4466-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4466-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4466-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-376-g9f12bfe2-1 all WebRTC compatible Selective Forwarding Unit (SFU)

Firewall rule added to both
4096/udp ALLOW Anywhere
4096/udp (v6) ALLOW Anywhere (v6)

JVB on server 1
[Tue Apr 20 12:48:02 BST 2021] INFO Added new videobridge: Bridge[jid=jvbbrewery@internal.auth./fa33b939-66f3-4d84-8643-8e4f63581e98, relayId=<public_ip>:4096, region=region1, stress=0.00]

JVB on server 2
[Tue Apr 20 12:48:59 BST 2021] INFO Added new videobridge: Bridge[jid=jvbbrewery@internal.auth./bridge3, relayId=<public_ip>:4096, region=region1, stress=0.00]

Jicofo log is in here

Check if this helps OCTO issues in latest installation - April 17, 2021

Hi
Thanks for that, I have octo enabled set in jicofo.conf, but I also have to set in the jvb.conf as well?
Thanks

If you check that post, you can observe that the extra parameter ‘id’ seems to have worked.

Yeah i put that id in, but didnt make a difference

All solved
Thanks

What did you do? Post it so that it would help others.

1 Like

It was actually a bit of a mess with our jitsi meet install
We had installed jitsi meet with installation package, and then a month later tried to build from a version from the Git Repo
Some of the libs pointed from nginx were pointing the packaged version and some to the built version
We reverted to point everything to the installed version and it all was working

in addition: since a commit on the 2. dec 2020 the logging “octo_enabled” in jicofo was removed