Jitsi Not working with more than 2 participants

I use jitsi for my project, it’s was working perfectly using meet.jitsi
then i deployed my own server following the documentation and hosted it and it was certified.
the problem is when there are more than 2 participants in the room ( jitsi no more use p2p ) they can’t hear each other or see camera or even share screen and i get this errors ( sometimes it also happens with 2 peoples too )

1 Like

i was wondering if this is related to certificate because when i make a ssl chain checker for my domain i get like this

This is network issues check out htrps://jitsi.org/qi advanced section

Hello damencho ,
thank you for your quick reply
i followed these links Self-Hosting Guide - Docker, Install guide for kubernetes for deploying

No worries, same ports are needed and for that deployment. You need to make sure outside world has access to port UDP 10000 and that your jvb is announcing its correct public address.

when a third person tries to connect i get this error on jvb log
Pair failed: ->

Is your port 10000/UDP open and accessible as damencho advised?

thank you, I had to enable it explicitly on the cloud interface

Hey, with the latest release some days ago my same terraform script no longer works with more than 2 participants on a call.

Do you know what has changed in the latest release that led to this regression?

I have manually forced the previous release of Jitsi and now everything is working again.

There is a migration that happened to WebSockets.
I updated the configurations as mentioned in the FAQ. How to migrate away from multiplexing and enable bridge websockets.
Then there was a network issue- it is solved by enabling the UDP port 10000.

Thank you guys , now it works the problem was with cloud azure ip address configuration
it’s working now with more than 2 participants but there are some feature that does not work like :
Sharing youtube video ( only who shared can see the video , others participants can only see a thumbnail of the video )
Streaming a youtube video gives an error , althought it works with meet.ji.si .
Also Speaker stats giving 0 seconds
i think the problem comes from cloud azure if anyone got an idea