Jitsi not working on enabling Hide.me proxy

Hi,
On enabling Hide.me proxy extension , participant will no audio video and voice and it show
connection lost in network status.
For that we tried setup co-turn server and tested with tool https://webrtc.github.io/samples/src/content/peerconnection/trickle-ice/
it shows us connected Hide.me proxy disable , but on enable again it show unreachable.

Any Help, suggestions

Hi ,
When i start meeting in https://meet.jit.si/ and enable Hide.me proxy extension, it is working fine,
but when i start meeting at our end configured jitsi server and enable Hide.me proxy extension it was not working.
on disabling the extension it was working like a charm
any help?

Hello
while I’m not knowledgeable in the ‘Webrtc IP address showing problem’ I wonder if it’s not that when the trick is to force the ‘business mode’ - connection through 443 port only. Can you connect to your Jitsi-meet server without your extension but with a firewall blocking the UDP/10000 port ? If not, maybe making the coturn server actually work could solve your problem. Coturn works on meet.jit.si, of course.

@gpatel-fr when we tried setting the coturn server while trying to verify it connectivity using https://webrtc.github.io/samples/src/content/peerconnection/trickle-ice/ the connection failed when Hide.me proxy was enabled. It connected when hide.me proxy was disabled. The extension has a webrtc blocker setting enabled by default which I think doesn’t send the true ip of the client, thus causing connection failure.

Any clues how does meet.jit.si bypass this webrtc blocker?

What I was suggesting is to test if your coturn setup works first, with a standard, basic connection. Then when you can connect without the port 10000, test with your extension.