Jitsi not picking up call from Voximplant

This is the sip user for the sip (vox) side. But the XMPP side of things, the jitsi-meet part you need a username and password to access it … so you need to create a user for jigasi and set it up as int the example link I showed you.

Yes. This is coming from the custom sip header sent X-ROOM…

I have these three lines enabled in sip-communicator.properites:

org.jitsi.jigasi.xmpp.acc.USER_ID=
org.jitsi.jigasi.xmpp.acc.PASS=
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

I believe the link you sent is this:

[https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.properties#L92 ]

Sorry for the silly questions, do I have to set up that user in another place? Is the Voximplant user or the Jigasi User the one to be used?

Thank you for your time.

My jitsi-meet user id is bbrout@rasl
my Voximplant user is Jitsi-call-in-user

Or do I make up a separate user?

sorry, stuff got hidden. There are the lines:

org.jitsi.jigasi.xmpp.acc.USER_ID=bbrout@rasl.ca
org.jitsi.jigasi.xmpp.acc.PASS=MYPASSWORD
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

I had tried this:

org.jitsi.jigasi.xmpp.acc.USER_ID=Jigasi-dial-in-user@jigasi.bbrout.n2.voximplant.com
org.jitsi.jigasi.xmpp.acc.PASS=VOXIMPLANTUSERPASSWD
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

Neither worked unfortunately.

It should be a user that you can use to login to your deployment when using the web for example

Sorry for my confusion. My deployment, would that be my droplet??? That is where I have my server running jitsi, etc.

I do not understand what you mean by deployment. I have a jitsi user and password that allows me to open a new room I tried that but it didn’t work.

Your deployment is jitsi.physical-truth.com.

Hum. Ok on the machine where jitsi-meet is installed do:

prosodyctl register jigasi auth.jitsi.physical-truth.com somepassword

And in jigasi config you need to have:

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@auth.jitsi.physical-truth.com
org.jitsi.jigasi.xmpp.acc.PASS=somepassword
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

That caused something different to happen. It went all the way to the voice message “connecting you to your conference. Please wait.” Then it hung up after about a second.

I ran prosodyctl register jigasi auth.jitsi.physical-truth.com somepassword

In /etc/jitsi/jigasi/config I inserted the three lines

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@auth.jitsi.physical-truth.com
org.jitsi.jigasi.xmpp.acc.PASS=somepassword
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

then in /ect/jitsi/jigasi/sip-communicator.properties replaced three lines with

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@auth.jitsi.physical-truth.com
org.jitsi.jigasi.xmpp.acc.PASS=somepassword
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

I saved and restarted the servers and tried calling in. The room is called test_room.

I have updated the logs files and sip-communicator.properties in my drive. I have also included the jigasi config file.

BTW thank you for all your help

Fix this and check jicofo logs for errors.

It works.

The last error was in jitsi.physical-truth.com-config.js where this should have been:

dialInConfCodeUrl: "https://api.jitsi.net/conferenceMapper",

I had that all messed up and after correcting, it now works. Thank you so much for going all through this with me. I am rather grateful.

I hop I may be able to help others go through this. I think I’ve made every mistake that could be made.