Jitsi not picking up call from Voximplant

This is suspicious:

2020-10-16 18:10:25.804 SEVERE: [70] impl.protocol.sip.SipStackSharing.findTargetFor().922 no listeners
2020-10-16 18:10:25.806 SEVERE: [70] impl.protocol.sip.SipStackSharing.processRequest().709 couldn't find a ProtocolProviderServiceSipImpl to dispatch to

I also saw you are running java 14. Can you run java8, as this is the one that for sure is tested with?

that sounds like a very good idea. I just used the droplet vanilla and I will try running java8.

I have tired downgrading to java 8 and stopped and restarted servers. I then tried calling in again, which did not pick up and then uploaded fresh log files back into my drive. You should still have the link to the drive.

From the last jigasi.log I can see it picks up the user Jigasi-dail-in-user ok and it “hears” a call-in. Then the XMPP Service fails to connect.

lines near end of jigasi.log:

2020-10-16 20:00:08.177 INFO: [72] org.jitsi.jigasi.JvbConference.start().437 [ctx=16028784071542108328870] Starting JVB conference room: voximplant@conference.jitsi.physical-truth.com?conference=algebra-classroom@conference.jitsi.physical-truth.com
2020-10-16 20:00:08.248 INFO: [72] org.jitsi.jigasi.JvbConference.setXmppProvider().576 [ctx=16028784071542108328870] Using ProtocolProviderServiceJabberImpl(Jabber:0a0bbd03@jitsi.physical-truth.com/0a0bbd03)
2020-10-16 20:00:08.449 INFO: [75] impl.protocol.jabber.OperationSetBasicTelephonyJabberImpl.registrationStateChanged().127 Jingle : ON
2020-10-16 20:00:08.450 INFO: [75] org.jitsi.jigasi.JvbConference.registrationStateChanged().627 [ctx=16028784071542108328870] Registering XMPP.
2020-10-16 20:00:08.450 SEVERE: [75] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service
org.jivesoftware.smack.SmackException: No supported and enabled SASL Mechanism provided by server. Server announced mechanisms: [SCRAM-SHA-1, SCRAM-SHA-1-PLUS, PLAIN]. R

How to correct the XMPP service from not connecting?

Share you jigasi sip-communicator.props config file.

I have uploaded it tothe drive with the other log files. This is the link

sip-communicator.properties

Thank you.

Try adding org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true and try again

Thank you. I have added that line into /etc/jitsi/jigasi/sip-communicator.properties and tried again. It still did not connect.

jigasi log states

2020-10-17 20:32:18.727 SEVERE: [70] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service

I have updated log files in drive folder

I see two problems, your deployment requires authentication while your jigasi is not using authentication, you need to create a user for jigasi and use it here: https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.properties#L92

And the room you are passing looks wrong: voximplant@conference.....?conference=algebra-classroom@conference.....

Should be either voximplant@conference..... or algebra-classroom@conference.....

I have changed sip-communicator.properties to have the user Jigasi-dial-in-user@jigasi.bbrout.n2.voximplant.com which should be the host user.

the room name is Algebra-classroom. Complete name of room is jitsi.physical-truth/Algebra-classroom.

I am confused regarding passing the room. Would that be on the Voximplant side. I see this in jigasi.log

2020-10-17 20:32:18.418 INFO: [67] org.jitsi.jigasi.JvbConference.start().437 [ctx=1602966737380725155852] Starting JVB conference room: voximplant@conference.jitsi.physical-truth.com?conference=algebra-classroom@conference.jitsi.physical-truth.com

Yeah, that does look messed up. Does that come from the Voximplant side or from my jitsi set-up?

Thanks again for your help.

This is the sip user for the sip (vox) side. But the XMPP side of things, the jitsi-meet part you need a username and password to access it … so you need to create a user for jigasi and set it up as int the example link I showed you.

Yes. This is coming from the custom sip header sent X-ROOM…

I have these three lines enabled in sip-communicator.properites:

org.jitsi.jigasi.xmpp.acc.USER_ID=
org.jitsi.jigasi.xmpp.acc.PASS=
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

I believe the link you sent is this:

[https://github.com/jitsi/jigasi/blob/master/jigasi-home/sip-communicator.properties#L92 ]

Sorry for the silly questions, do I have to set up that user in another place? Is the Voximplant user or the Jigasi User the one to be used?

Thank you for your time.

My jitsi-meet user id is bbrout@rasl
my Voximplant user is Jitsi-call-in-user

Or do I make up a separate user?

sorry, stuff got hidden. There are the lines:

org.jitsi.jigasi.xmpp.acc.USER_ID=bbrout@rasl.ca
org.jitsi.jigasi.xmpp.acc.PASS=MYPASSWORD
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

I had tried this:

org.jitsi.jigasi.xmpp.acc.USER_ID=Jigasi-dial-in-user@jigasi.bbrout.n2.voximplant.com
org.jitsi.jigasi.xmpp.acc.PASS=VOXIMPLANTUSERPASSWD
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

Neither worked unfortunately.

It should be a user that you can use to login to your deployment when using the web for example

Sorry for my confusion. My deployment, would that be my droplet??? That is where I have my server running jitsi, etc.

I do not understand what you mean by deployment. I have a jitsi user and password that allows me to open a new room I tried that but it didn’t work.

Your deployment is jitsi.physical-truth.com.

Hum. Ok on the machine where jitsi-meet is installed do:

prosodyctl register jigasi auth.jitsi.physical-truth.com somepassword

And in jigasi config you need to have:

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@auth.jitsi.physical-truth.com
org.jitsi.jigasi.xmpp.acc.PASS=somepassword
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

That caused something different to happen. It went all the way to the voice message “connecting you to your conference. Please wait.” Then it hung up after about a second.

I ran prosodyctl register jigasi auth.jitsi.physical-truth.com somepassword

In /etc/jitsi/jigasi/config I inserted the three lines

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@auth.jitsi.physical-truth.com
org.jitsi.jigasi.xmpp.acc.PASS=somepassword
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

then in /ect/jitsi/jigasi/sip-communicator.properties replaced three lines with

org.jitsi.jigasi.xmpp.acc.USER_ID=jigasi@auth.jitsi.physical-truth.com
org.jitsi.jigasi.xmpp.acc.PASS=somepassword
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

I saved and restarted the servers and tried calling in. The room is called test_room.

I have updated the logs files and sip-communicator.properties in my drive. I have also included the jigasi config file.

BTW thank you for all your help

Fix this and check jicofo logs for errors.

It works.

The last error was in jitsi.physical-truth.com-config.js where this should have been:

dialInConfCodeUrl: "https://api.jitsi.net/conferenceMapper",

I had that all messed up and after correcting, it now works. Thank you so much for going all through this with me. I am rather grateful.

I hop I may be able to help others go through this. I think I’ve made every mistake that could be made.