Jitsi Mobile (Secured with Valid Cert)

We have a valid cert installed for our Jitsi Custom Server, joining on a room via mobile already prompted us a login page(no more black screen)

  • Configured secured domain
  • Creating and joining a room in desktop works
  • meet.jit.si works too when joining via phone on a room (audio and video)

But joining via phone application doesn’t connect us inside the room, we we’re prompted a red screen showing a connectivity issue. Just asking for some advice on here. TIA

Make sure you have the whole chain of certs installed on the server.

Yes we installed it all, but it keeps disconnecting us after joining on a room.

On our mobile jitsi we tried

  • Creating a room via mobile (successful - voice and camera activated)
  • Entering the room (successful login and voice and camera activated) we only see ourselves and not the other party. Only the avatar is shown.
  • After a certain time from joining the host room (about 10-20 seconds I got this RED SCREEN showing an error)

Have you tried entering with 3 participants from desktop, does it work?

1 Like

Yes desktop platform works, with 3 or more participants, the only problem is on the mobile platform.

Do we need to open some ports for mobile? Because we think that it is an issue on the firewall.

Nope samo ports as when using it from desktop. Can you try opening chrome and open the url, do you see a warning about the certificate?

After installing the valid certificates, there are no more warnings encountered.
(Tested with chrome and other browsers)

We also tried disconnecting to our VPN and creating a room was successful, however if we joined we would get black screen and only the avatar is shown, both mobile and browser.

PS: NAT is already configured.

Are you using wifi or mobile data?
So you say without VPN it works and with VPN it doesn’t work?

Wifi connection.
It’s actually reverse, connected with VPN will let us join the room without any problems audio and video good.


Picture: Tried connecting mobile on a room created on desktop. After logging in the mobile, we can’t see each other.

If it succeds with VPN, I suspect the settings about addresses in jvb are wrong and it advertises addresses which can be accessed only when you are on VPN.

1 Like

Update = Solved - changed some settings on addresses, much thanks.

can you tell me about ip setting? please same issue

Hi, how you solved?

i solved \o/

you need allow 10000-20000 port in your firewall/router.