Jitsi - mobile app (android or IOS) don't connect to meetings

Need help configuration jitsi server.

What i did:

  1. Install Debian10
  2. Install Jitsi meet
  3. setup sertificates.

Сonferences are opened in the browser without problems. When I try to connect from a mobile app, an error occurs:


can’t see your logs,

could you share them here ?

Also how you installed jitsi?

you have failing pairs in your jvb.log. Usually it means connectivity problem on port 10000; yet you say that your PC are connecting fine. Could it be that your computers are on a private network and connect directly, not from the nternet ?

1 Like

i can’t upload log’s here - i’m new user (
i will do reload log’s on other fileserver - Filecloud.me – most simple file sharing

yes. Server published on internet.

Seems like your certificate chain is not generated correctly, Search for sectigo certificate chain

1 Like

as @emrah said your ssl certs are not working properly.

portmanager error Error binding encrypted port for https: No certificate present in SSL/TLS configuration for https port 5281

This is actually harmless. But yes, the observations reported by the OP suggest cert problems, especially if it’s accurate that desktop browsers are able to connect, but mobile devices can’t.

1 Like

as said try to remove the root certificate from the chain. This site explains the details.

1 Like

i did reconfig nginx with new chain. This fixed it. TNX!

Hi there,

sorry to bring up the old topic again, but I’m struggling on this right now.
Jitsi in browser is working fine. But app shows error: Connection lost.

We recently changed our domain including the certificate (btw: wild-card). But I’m unsure what exactly to do and ask for assistance.

In /etc/nginx/sites-available/LOCALSERVERNAME.LOCALDOMAIN.conf I have a self-signed certificate for our local Jitsi server:

ssl_certificate /etc/jitsi/meet/LOCALSERVERNAME.LOCALDOMAIN.crt;
ssl_certificate_key /etc/jitsi/meet/LOCALSERVERNAME.LOCALDOMAIN.key;

Is that wrong?

Thanks in advance!

AFAIK mobile apps don’t support self-signed certificates.
If there is a way to add your CA certificate into the mobile device, it may work

Thank you emrah for the fast response.

I allready read that self-signed certificates are not supported by mobile apps.
In our environment, we use a web-application-firewall (WAF) for the jitsi website which has a valid public certificate.
Could it be that the app doesn’t recognize that by any way?
I can pm you the url if you want…

  • Are the browser clients in the local network?
  • Are the mobile clients in the local network or are they using the mobile network?
  • Does your WAF support websocket?
  • Are the browser clients in the local network?
    I’m testing with external clients. Nevertheless, clients from inside and outside are working. Only Jitsi app isn’t working from outside. The only thing I cannot test is Jitsi app from local network.
  • Are the mobile clients in the local network or are they using the mobile network?
    I tested both with wireless lan and mobile network - same result
  • Does your WAF support websocket?
    Yes, I have option ‘Websocket Passthrough’ activated. But I don’t have websockets activated within Jitsi. As I did that my whole Jitsi worked only with very low resolution. I opened another thread on that some days ago: Problems with webSockets? - Install & Config - Jitsi Community Forum - developers & users

Can you share config.flags lines from your config.js

Here you are:


    // Allow all above example options to include a trailing comma and
    // prevent fear when commenting out the last value.
    makeJsonParserHappy: 'even if last key had a trailing comma'

    // no configuration value should follow this line.

/* eslint-enable no-unused-vars, no-var */
config.flags.sourceNameSignaling = true;
config.flags.sendMultipleVideoStreams = true;
config.flags.receiveMultipleVideoStreams = true;

I am testing with Jitsi mobile app version 22.7.1 build 12419976

The following line is missing in your config.js. Can you add it?

config.flags = config.flags || {};

That did the trick, it’s working now! Big thanks mate :+1:
I think the community here is really great.
Have a nice weekend!

1 Like