Jitsi Mobile App and Jitsi Mobile SDK failed to load config file on latest Jitsi Self Deployment Server

Hi, I have this unknown issue, and I’ve been stuck with it for the past few days.
It is not my first time deploying the Jitsi server and it never happens to me before on the old version of Jitsi.

I have Jitsi deployed before on the public server with the Jitsi-meet version 2.0.7830-1 and it works without a problem, I can connect to this server from a browser, Jitsi SDK 5, and even from the latest Jitsi Mobile App and Jitsi Mobile SDK v7.0.1 without issue whatsoever.

Then I create a new public server with the newly released Jitsi-meet version 2.0.8138. I install it, as usual, set the DNS name, and use Letsencrypt for the SSL certificate. I test it on a browser and it works as expected, but when I test it on mobile the issue happens.

When I looked into Logcat it showed that JitsiMeetSDK Failed to load the config. I test using the latest Jitsi Mobile app also Jitsi Mobile SDK versions 6 and 7 but still with the same result.

I know this usually happens when the certificate chain is not correctly installed, but when I check on https://www.digicert.com/ it showed that it is correct.

The only thing I changed on its meet config is to disable p2p, just like my old working Jitsi server. Did I miss something? or there are new configurations with the latest Jitsi Meet that I need to change?

Try setting the following flags in your config.js:

flags: {
        sourceNameSignaling: true,
        sendMultipleVideoStreams: true,
        receiveMultipleVideoStreams: true,
1 Like

Woah man you are my savior, I didn’t suspect it at all because you see that flags are already there in the config file.

Turns out it is not working on mobile I guess with that kinda declaration? and when I add it specifically as you suggest then my mobile app starts working again like a charm :+1:

Screenshot 2022-12-14 at 12.15.15

Btw is this only happening to me or what? it has been a week since the latest Jitsi-meet web release with that default config file but I can’t find any issue related to that flag declaration.

anyway, thanks a lot @Freddie

I think this is buggy and already fixed on the master branch but not in the stable release yet.

The following line is needed before these lines:

config.flags = config.flags || {};
1 Like