Jitsi Meets need to use your microphone and camera

Hi guys. My kid’s school decided to use your brilliant program for online lessons. Despite all efforts, couldn’t go beyond “Jitsi Meets need to use your microphone and camera”. Of course, I gave this site every freaking permission it needed, but for whatever reason it refuses to work. All about security and safety but who gives a sh…t if it disallows you to use it? The most disgusting experience in my life. Thanks.

Sorry to hear that. Can you give more details. Browser, operating system, version?

Hi, I have the same problem.
Windows 10 home, version 1909, build 18363.720 (64 bit)
Chrome, version 80.0.3987.149 (Ufficial Build) (64 bit)
Can you help us, please?

Thanks!

Image1|690x387

I suspect some app firewall or extension is blocking webrtc. Have you tried in incognito? Or does this work for you https://test.webrtc.org/?

hi, i have the same problem but at the link you posted nothing happend … same problem. sadness

Apparently this problem has nothing to do with firewalls, cookies, Chrome extensions, incognito mode etc. I’ve tried it all and just wasted my time. There’s something in between Windows and Chrome itself. It’s just a matter of a random case. In my particular one, the’s no any single site which can use the camera in Chrome, including WebRTC, which says: "To test your webcam, microphone and speakers we need permission to use them, approve by selecting “Allow”.

If you’re lucky enough to have a particular Windows version (nobody knows which one works - it’s still a mystery like an anti-coronavirus vaccine), everything is gonna be fine. Otherwise, it WON’T WORK, no matter how hard you try. FYI there’s a topic on the google support page: https://support.google.com/chrome/thread/2062037?hl=en.
In general, it just depicts how crappy browser Chrome is. Some other ones like Firefox would have worked, but - ups! They all don’t belong to your “list” of supported browsers (where there’s nothing but Chrome).

Sorry to hear about all the trouble with Chrome.

I am currently uing Chrome and Firefox without any problems:
Windows10 Pro 64bit V1903 build 18362.720 0n Dell E5440
FireFox 74.0 64bit, Chrome Version 80.0.3987.149 (Official Build) (64-bit)
I did have some problems with my Mic until I found the privacy settings in The “Sounds” app in control panel.

Regards

I have a PC with Win10 on it and there it works. But on a laptop with Win 8.1 it sucks. I suppose that the only way to fix the bug is to upgrade Win 8.1 to Win10. However I’m not sure that it will help considering how many cases of the problem with Win 10 are mentioned on various forums.

Finally.
Upgraded Windows 8.1 to 10.0 and it fixed the bug. Nothing else could help.
So the only solution in my particular case was to install Windows 10 instead 8.1.

Good evening,
similar situation here,
TL;DR: it seems to be an issue from JITSI app reading out CHROME permission.

In Details :

  • Server: meet.jit.si and meet.ffmuc.net
  • Two different Win10 installations (personal and company computer)
  • Mozilla Firefox works fine
  • Chrome can use camera, e.g. for teams or webex sessions
  • JITSI in Chrome claims “Permission not granted”

Chrome versions:

  • Version 80.0.3987.149 (Offizieller Build) (64-Bit)

As workaround, use Mozilla Firefox - works fine for me

@JoschHH can you open https://test.webrtc.org, click Start and then send us the report? Thanks.

1 Like

Can you check if Windows Microphone privacy settings are blocking your microphone?
https://support.google.com/chrome/thread/2062037?hl=en&msgid=28511121

Search (win+S) 'Microphone privacy settings'
Check 'Microphone access for this device is On/Off' 
Change to 'On'
Then scroll down to 'Allow desktop apps to access your microphone'
Turn 'On'

https://test.webrtc.org/report/AMIfv97LAjk4cLo8mnfannKDbZoyb9U0fOyYgi3cahrPT6EvZKj2MoI4BQjbVU8_Mq1B7NaOB57VdV2cpMGYZzxzegb9808mcOeQX_M9ReorBIx1ybD4sKSCVzvyTKhGxdBIwhkliRp6Vfzvz8c2q6qYnnUMzl4Myg

I think your browser does not have permissions to use the camera and mic. Some windows privacy setting … I’m not exactly aware where to check for it.

Good Evenning, I have checked your site http://meet.ffmuc.net/ and everything works fine without any problems. The issue I have observed with my users is that most of them do not control settings in Chrome, however if you enforce clearing all of them ( I recommend to test with the Chrome and Firefox portable from portable appps) you will see that it will work. For duty pc’s I have enforced that when the user close the browser everything is cleared and just only left a simple link to the url in bookmark. Simply saying go to Chrome>settings>advanced>privacy settings and adjust accordingly to your needs.

Found it!
The “Access to microphone” was blocked under Win10. This leads to jitsi claiming “Access to camera is blocked”.

So:

  • Mic on, Camera on -> works fine
  • Mic on, Camera off -> works audio
  • Mic off, Camera on -> does not work

Thanks damencho :slight_smile:

1 Like

I have the same issue, it doesn’t work with Chrome 64-bit, but no issue when is use the 32-bit version.

Borrando el historial de navegación, ademas de bloquear la cámara desde los permisos del navegador y luego volviendo a desbloquear, me funcionó. Ojala les sirva

I have similar problems here - very frustrating as I’ve pushed Jitsi as a good solution for interacting with our customers but I now find it’s pretty much unusable on my desktop:

  1. Chrome used to work find on my desktop machine (Win 10 v 1909). Now it says “Jitsi Meet needs to use your microphone and camera” - these are both already enabled but it never progresses past this message. If I disable from chrome settings Jitsi takes me through the step of allowing access but still doesn’t progress from there.

Fortunately Jitsi does work in chrome from may laptop (Win 10 v 1809) so that saved my bacon this morning

  1. Firefox: The camera works fine but I have a number of audio sources and it defaults to the wrong one. The microphones dialogue won’t allow me to select the correct one.

  2. Edge/IE - unsupported - some of our users wouldn’t have a clue how to install a browser on their PC/Laptop so they’re stuck with Edge. Unfortunately that makes jitsi a non-starter for certain types of shared meeting - such a shame because these are just the sort of people a browser based solution would be great for.

I love the concept of Jitsi but having struggled with these issues for a week or so now I’m afraid it looks like we’re going to have to look to another solution :frowning: