Jitsi meet | websocket connection failed (no audio and video)

Hi community,

I have an openstack cloud on vps with a public address and i installed jitsi on-premise using this official guide on ubuntu bionic instance.

In my local network jitsi works fine, but it not work in case 2 users or more with different networks (sometimes i can hear some words and noisy).

I have this error in the console.

And this in jvb.log :
2021-04-06 15:40:51.280 WARNING: [21] [confId=78831d92fd7fabdf epId=cfc7a18a gid=52561 stats_id=Christopher-5GU conf_name=esd@conference.X.X.X.X] Endpoint.acceptWebSocket#1016: Incoming web socket request with an invalid password. Expected: 3ctlbs4mfpcip4b0ctmho3s3v0, received 49cr9iu4t9ko7q0u9lkqvcg91n
2021-04-06 15:40:53.180 INFO: [16] HealthChecker.run#170: Performed a successful health check in PT0S. Sticky failure: false
2021-04-06 15:40:53.728 INFO: [77] [confId=78831d92fd7fabdf gid=52561 stats_id=Christopher-5GU conf_name=esd@conference.X.X.X.X ufrag=ejorm1f2jtbuq4 epId=cfc7a18a local_ufrag=ejorm1f2jtbuq4] ConnectivityCheckClient.processTimeout#860: timeout for pair: X.X.X.X:10000/udp/srflx → 172.24.4.10:39715/udp/prflx (stream-cfc7a18a.RTP), failing.
2021-04-06 15:41:02.730 INFO: [77] [confId=78831d92fd7fabdf gid=52561 stats_id=Christopher-5GU conf_name=esd@conference.X.X.X.X ufrag=ejorm1f2jtbuq4 epId=cfc7a18a local_ufrag=ejorm1f2jtbuq4] ConnectivityCheckClient.processTimeout#860: timeout for pair: X.X.X.X:10000/udp/srflx → 172.24.4.10:39715/udp/prflx (stream-cfc7a18a.RTP), failing

i have set iptables rules :
-A FORWARD -d 172.24.4.133/32 -p tcp -m tcp --dport 443 -j ACCEPT
-A FORWARD -d 172.24.4.133/32 -p tcp -j ACCEPT
-A FORWARD -d 172.24.4.133/32 -p udp -j ACCEPT
-A FORWARD -d 172.24.4.133/32 -p tcp -m tcp --dport 443 -j ACCEPT
-A FORWARD -d 172.24.4.133/32 -i enp -p udp -m udp --dport 10000 -j ACCEPT
-A FORWARD -i enp -o br-ex -p udp -m udp --dport 10000 -j ACCEPT
-A FORWARD -i br-ex -o 172.24.4.133 -p udp -m udp --dport 10000 -j ACCEPT
-A FORWARD -d 172.24.4.133/32 -p tcp -m multiport --dports 10000:20000 -j ACCEPT
-A FORWARD -d 172.24.4.133/32 -p udp -m multiport --dports 10000:20000 -j ACCEPT

-A PREROUTING -i enp -p udp -m udp --dport 10000 -j DNAT --to-destination 172.24.4.133:10000
-A PREROUTING -i enp -p tcp -m tcp --dport 4443 -j DNAT --to-destination 172.24.4.133:4443
-A PREROUTING -i enp -p tcp -m tcp --dport 4444 -j DNAT --to-destination 172.24.4.133:4444
-A PREROUTING -i enp -p tcp -m multiport --dports 10000:20000 -j DNAT --to-destination 172.24.4.133
-A PREROUTING -i enp -p udp -m multiport --dports 10000:20000 -j DNAT --to-destination 172.24.4.133

more infos :

  • I set NAT configuration
  • Firewall is disabled

Thanks

I have the same problem, have you solved it?

No, still got the same error.
Please community help

You only need TCP/9090 and UDP/10000 for JVB

And the correct config… Check this

Why is required to allow port 9090/tcp? I have followed this guide: Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook and this port is not mentioned

TCP/9090 is used for websockets. The guide you linked is not for the additional JVB, this port is needed for the additional JVBs.