Jitsi Meet via Docker: disable recording- and livestream-button

Dear colleagues.

I’m not using Jibri, however the functions are still made available to the users in the menu.

When operating Jitsi Meet via Docker, is there a way to deactivate the recording- and livestream-button in the menu for the users without changing the source code?

Not really familiar with docker, but I believe you can just set those two to “no”/“false” in your .env.

Here is the template for “.env”:

I can’t find a way to disable button availability in the template.

Try ENABLE_RECORDING=0

It already is. The feature is disabled, but the buttons are still visible to users.

Ah, you can configure the toolbar buttons you want to show up here:

So you would list the buttons you want to show up; anything that’s not listed should be hidden.

Thanks very much.

While this looks good, TOOLBAR_BUTTONS doesn’t seem to have any effect.

For example, if I configure TOOLBAR_BUTTONS=camera,chat,closedcaptions,desktop the following configuration is still generated after restart in “config.js” and the buttons remain:

// toolbarButtons: [
//    'camera',
//    'chat',
//    'closedcaptions',
//    'desktop',
//    'download',
//    'embedmeeting',
//    'etherpad',
//    'feedback',
//    'filmstrip',
//    'fullscreen',
//    'hangup',
//    'help',
//    'invite',
//    'livestreaming',
//    'microphone',
//    'mute-everyone',
//    'mute-video-everyone',
//    'participants-pane',
//    'profile',
//    'raisehand',
//    'recording',
//    'security',
//    'select-background',
//    'settings',
//    'shareaudio',
//    'sharedvideo',
//    'shortcuts',
//    'stats',
//    'tileview',
//    'toggle-camera',
//    'videoquality',
//    '__end'
// ],

Possibly a bug?

So make that change in config.js. I know there are two config.js files in docker (one doesn’t hold changes), so change it in the right one.

Maybe in a older version?

There is only one “config.js” on the system ("~/.jitsi-meet-cfg/web/config.js"). This file will be generated on any start.

This seems to be a work in progress:

I took a quick look at the docker guide. It says right there:

" These files are re-created on every container restart. If you’d like to provide your own settings, create your own config files: custom-config.js and custom-interface_config.js ."

So, in essence, you need to create your own custom config and place it in .jitsi-meet-cfg. Jitsi will automatically pick up the custom-config.js if it exists. I suggest going through the guide.

I’ve overlooked. I’ll try that. Many, many thanks for your help!

This is how it works perfectly.

In the “custom-config.js” file, the lines

config.fileRecordingsEnabled = false;
config.liveStreamingEnabled = false;

must be added.

Once again, thank you very much for your help.