Jitsi-meet under opera/firefox

My Jitsi-meetings only run correctly under chrome. I would prefer opera or firefox. Will it help to install the software?