Jitsi Meet Tokens cant Authorize


#1

Hi All,

I have an issue with authorizing user to my jitsi server with prosody. Installation was OK and public jitsi chatroom seems also working OK, but authorization with use of token is not working and I am getting “Authorization failed” - “Sorry you are not allowed to join to this call” message.

My Jitsi domain: https://con.aztut.ml
My JWT generator with encode and decode data: http://turkel.al/jwt_test/jwt.php

Please advise, most probably this is simple config issue but since long hours I was not figure it out yet :frowning:

Let me know which logs and config files required for review.

Regards,
Turkel.


#2

Can you try removing the group from your jwt. The group 123, means you are accessing the conference as https://con.aztut.ml/123/someroom


#3

I did same error, currently I am trying “test” room, do I need to define it anywhere ?

Something like:


#4

If you have in the token room:* this means all room names are allowed with that token.


#5

OK
What else could be the reason? how can I debug this app, I really need to make it work and also learn the installation process.


#6

Try looking at the XMPP traffic in Chrome’s network tab. It should tell what is exactly wrong with the token (is it expired, wrong room or something else).


#7

So first I got this from http-bind:
https://pastebin.com/aLE1Lr3P

Then second received data from http-bind is:
https://pastebin.com/Jn7TFJZF

Second one says terminate :S couldn’t got what actually these responses means.


#8

Anyone can help me please :frowning:

I have following logs on prosody.log:
https://pastebin.com/jtHUCmAN

No Prosody error logs.


#9

Can you paste your prosody config?


#10

And also check the logs of prosody on restart, do you see anything related … like not able to load module …


#11

These are config files:
http://turkel.al/prosody.zip

I have restarted prosody. logs shod only debug info not errors


#12

Your configs seems a little bit messed up.
First, you have two definitions of VirtualHost "con.aztut.ml", get rid of the one in the main prosody config prosody.cfg.lua.
Then in the con%00.aztut.ml.cfg.lua under VirtualHost "con.aztut.ml" you have authentication definition twice, you need to leave only the one with ‘token’.
See whether anything changes after you fix those.


#13

You are awesome! The solution solved issue right away :slight_smile:

Thank you very much.