Jitsi Meet secure domain authentication

Hi forum , anyone had any problems?, securing the conference with jitsi meet, I am trying to add authentication to my conference, but I can’t get it to work.

version of Jitsi meet with Debian 11:

in the latest version the jicofo.conf file is modified, but I can’t get it to ask for authentication.

jitsi-meet                     2.0.7439-1                     all          WebRTC JavaScript video conferences
jitsi-meet-prosody             1.0.6260-1                     all          Prosody configuration for Jitsi Meet
jitsi-meet-turnserver          1.0.6260-1                     all          Configures coturn to be used with Jitsi Meet
jitsi-meet-web                 1.0.6260-1                     all          WebRTC JavaScript video conferences
jitsi-meet-web-config          1.0.6260-1                     all          Configuration for web serving of Jitsi Meet

jicofo.conf

jicofo {
 authentication: {
    enabled: true
    type: XMPP
    login-url: conferencia.mysuperdomain.com
 }
  xmpp: {
    client: {
      client-proxy: focus.conferencia.mysuperdomain.com
    }
    trusted-domains: [ "recorder.conferencia.mysuperdomain.com" ]
  }
  bridge: {
    brewery-jid: "JvbBrewery@internal.auth.conferencia.mysuperdomain.com"
  }

}

any advice/help?

I can confirm that the guide works if applied correctly.

You obviously skipped a few steps. :slight_smile: Check the Manual!

Sorry, I followed all the steps, but I only put the jicofo.conf file, where else could I see what could be happening, in the log files?

Did you update Prosody config too?

confere.txt (6.1 KB)

I uploaded my configuration conferencia.mysuperdomain.com.cfg.lua