Jitsi Meet SDK 2.0.0 for Android and iOS released!

#1

Hey there fellow Jitsters!

Today we are happy to announce the availability of the Jitsi Meet SDK 2.0.0 for Android and iOS. You can find it in our Maven repo and in CocoaPods respectively.

This release is a big milestone for the mobile SDK. It took several passes until we were happy with it and we leveraged what we learned integrating it in Atlassian’s and 8x8’s applications.

The 1.x releases didn’t have a specific cadence nor they were following any versioning scheme. We are now correcting that: starting with 2.0.0 we are adhering to semantic versioning. Each release (after this one) will come with a comprehensive changelog so SDK consumers can use the new features easily and adapt to changes. Current SDK users can check the new API documentation on the respective README files (Android, iOS).

Last (but certainly not least) we are providing sample Android and iOS projects which integrate the SDK. These projects (in Java and Objective-C for now, but Kotlin and Swift will be coming) are native mobile applications which showcase how simple it is to integrate the SDK in native mobile applications.

With :heart:, the Jitsi Mobile Musketeers.

1 Like
#2

hi when i build my own sdk artifacts/binaries, i run this command from the root of jitsi-meet project repository :

./android/scripts/release-sdk.sh /tmp/repo

and it shows me this error :

Error: Unable to resolve module lib-jitsi-meet/lib-jitsi-meet.min from /home/zied/jitsi-meet/react/features/base/lib-jitsi-meet/_.native.js : Module lib-jitsi-meet/lib-jitsi-meet.min does not exist in the Haste module map

This might be related to https://github.com/facebook/react-native/issues/4968
To resolve try the following:

  1. Clear watchman watches: watchman watch-del-all .
  2. Delete the node_modules folder: rm -rf node_modules && npm install .
  3. Reset Metro Bundler cache: rm -rf /tmp/metro-bundler-cache-* or npm start -- --reset-cache .
  4. Remove haste cache: rm -rf /tmp/haste-map-react-native-packager-* .
    at ModuleResolver.resolveDependency (/home/zied/jitsi-meet/node_modules/metro/src/node-haste/DependencyGraph/ModuleResolution.js:183:15)
    at ResolutionRequest.resolveDependency (/home/zied/jitsi-meet/node_modules/metro/src/node-haste/DependencyGraph/ResolutionRequest.js:52:18)
    at DependencyGraph.resolveDependency (/home/zied/jitsi-meet/node_modules/metro/src/node-haste/DependencyGraph.js:273:16)
    at Object.resolve (/home/zied/jitsi-meet/node_modules/metro/src/lib/transformHelpers.js:261:42)
    at /home/zied/jitsi-meet/node_modules/metro/src/DeltaBundler/traverseDependencies.js:391:31
    at Array.map ()
    at resolveDependencies (/home/zied/jitsi-meet/node_modules/metro/src/DeltaBundler/traverseDependencies.js:388:18)
    at /home/zied/jitsi-meet/node_modules/metro/src/DeltaBundler/traverseDependencies.js:261:33
    at Generator.next ()
    at asyncGeneratorStep (/home/zied/jitsi-meet/node_modules/metro/src/DeltaBundler/traverseDependencies.js:87:24)

Task :sdk:bundleReleaseJsAndAssets FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:sdk:bundleReleaseJsAndAssets’.

Process ‘command ‘node’’ finished with non-zero exit value 1

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.

BUILD FAILED in 4m 23s
160 actionable tasks: 136 executed, 24 up-to-date
so, can u help me to fix this please ? thanks

#3

Have you installed the dependencies with npm install first?

1 Like
#4

thanks saghul, now the build works succussfuly when i use yarn instead of npm but the maven repository is empty
what’s the problem here ?

BUILD SUCCESSFUL in 21m 53s
400 actionable tasks: 362 executed, 38 up-to-date
~/jitsi-meet
/tmp/repo ~/jitsi-meet
~/jitsi-meet
fatal: l’étiquette ‘android-sdk-2.1.0’ existe déjà

#5

Delete that tag.

1 Like
#6

Thanks it is fixed