Jitsi Meet Screen sharing not working

Hello, I was wondering if someone could give me some advice about the issue I am experiencing.
I have jitsi installed on an instance in aws, everything worked well for months until now when users started experiencing issues with the screen sharing feature.

Logger.js:154 2021-10-02T12:29:31.157Z [features/base/tracks] Failed to create local tracks ['desktop'] s {name: 'gum.screensharing_user_canceled', message: 'User canceled screen sharing prompt',

Logger.js:154 2021-10-02T12:29:31.158Z [conference.js] <Object.toggleScreenSharing>:  Failed to switch to screensharing s {name: 'gum.screensharing_user_canceled', message: 'User canceled screen sharing prompt', 

As I understood from other topics relating this issue, the problem starts with the updates from Chrome (chromium), I have checked it, once you downgrade to a pre v90 version of Chrome everything works. Opera still works and Vivaldi browser also due to the fact they still use older versions of chromium.

But now it is not working in Mozilla Firefox also, the errors are the same.
I launched a new instance with the latest updates from jitsi but this problem still persists.

If anyone has any ideas, I would appreciate it.
Thank You!


Same here. Clicking the button (toggle screen share) does nothing.

I updated my server today (latest Jitsi version) hoping it would fix the problem, but it didn’t.

I tested with Chrome and Edge.

Does anyone know if there’s a solution to this?

Thanks in advance.

I have the same problem. It happens with chrome 94. I it worked this morning with chrome 93, after an upgrade it stopped working

Update: In my case, since the external api displays jitsi in an IFrame, there is a need to allow display-capture. See the following link for explanation.


I just tested with latest Chrome 94 with meet.jit.si screen hare works.
Are you using your own deployment or meet.jit.si?
Can you post more details version of jitsi in case you are using your own deployment.
Test with meet.jit.si on your device with chrome version you have.
If you are running old Version of jitsi it could be due to dropping of old Plan B , though I ama not sure if chrome 94 has dropped it or not yet.

IIUC it has been dropped in 93. There is a possible extension until end of year (version 96) but I think it requires for the developer to ask for special authorization (a ‘token’). See this issue.
I have upgraded my test server to 6420 and don’t see any obvious problem with screensharing on 2 workstations running stable Chrome 94 (snap Ubuntu), that’s 94.0.4606.71.
There were some glitches with 6381 though.

Edit: oh yes there are still problems. I tried the presenter mode (is it the official name ? that’s enabling the video to get a picture-in-picture of the video embedded in the screen shared) and first on the observation station there was a very disgraceful screen switching to the main video screen before going back to the screen sharing (minor problem) but on the workstation doing the screen sharing Chrome 94 has gone absolutely mad gulping memory, until filling up the swap with the usual unpleasant consequences on Linux. Bad, bad…

Edit 2: trying same config but with Chrome 93, first problem is the same so it’s a Jitsi-meet problem (there was hardly a doubt), Chrome don’t hog the computer but everything else crashes: first the screen sharing, then the conference itself. Not much better. Presenter mode is currently dead on unstable (at least on Linux).

I am self hosting.

In my case, I think the issue is because I am working with an iFrame. When I try sharing the screen using Jitsi from within the iFrame, it doesn’t work. I tested directly in a separate page (non-iFrame version) and it worked.

So probably the browser (Chrome) is not responding to the request from within an iFrame? Any thoughts on how I could overcome this?

We’re alson using iFrame, experiencing exactly the same behavior. When trying non iFrame test sometimes it works, sometimes not. The only way iFrame or non iFrame screen sharing works is with older versions of chromium.

Do you think this should be reported as a bug? To be honest it seems to be about how the browser behaves…for me it is really annoying as my application relies on screen sharing a lot (online classes).

Also, I am not a developer so I am a bit lost about how to overcome this if there’s no update from Jitsi’s end to fix it.

Are you creating the iframe using the iframe API?

No; I just have a regular iFrame, where my Jitsi url shows. This is how I’ve been using it since January this year.

And do you have all these allow settings in your iframe?

In general, it is a good idea to use the iframe API as we are taking care of creating the iframe and passing all the needed params.

1 Like

Thank you; I don’t have these. I will test including these and will come back to confirm if it worked.

After updating the “allow” settings in my html, I can confirm it works in the iFrame.
Thank you very much!

Tried it again this evening and it was a computer problem. Don’t know which, but a more recent computer running Ubuntu 20.04 run the picture-in-picture without going mad, so it’s possibly a graphic driver bug specific to a specific hardware.

today my jitsi meet have the same issue , can not sharing screen on chrome browser ,in my windows already share screen ,but on participant only a black screen,

Please advice .


Is this on meet.jit.si or on your personal server?
I just tested on meet.jit.si and screensharing works fine. Checked with Chrome 96 and 97.

My jitsi on personal server, i’ve just know today, and on the share screen option there’s no option to select the pdf file, while the pdf file was opened on my desktop,

I’m using the latest version of chrome.

When i’m using firefox my participant can see my share screen but except the pdf file, because no option to select the pdf file on share screen tab menu,

And when using google chrome my share screen on participant just black screen, but in my desktop already sharing

I was able to share a pdf file opened in an image browser (Preview on Mac).

Are you only having this issue with pdf files or screen sharing in general?

upss sorry,

I already check , we can share pdf file , but when i share screen all participants see only the black screen, and all participant only can see their camera , even all participant’s camera are opened . that’s the problem , they can not see each other, so same happended with the share screen too, only the black screen.

i think i post on the wrong topics ,
so sorry …


The same kind of issue happened to me after upgrading my self-hosted jitsi setup using the docker-compose files provided. The problem is that the reverse proxy needs some new/updated configuration about an additonal endpoint (/colibri-ws) which was not needed in earlier jitsi versions. Once I updated the nginx reverse proxy config according to the installation manual, screen sharing worked like a charm with chromium, chrome and firefox.