Jitsi meet react-native Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0

Hello,
react-native run-android return :

info Starting JS server…
info Building and installing the app on the device (cd android && gradlew.bat app:installDebug)…
Starting a Gradle Daemon (subsequent builds will be faster)

Task :react-native-fast-image:compileDebugJavaWithJavac
Gradle may disable incremental compilation as the following annotation processors are not incremental: compiler-4.7.1.jar (com.github.bumptech.glide:compiler:4.7.1).
Consider setting the experimental feature flag android.enableSeparateAnnotationProcessing=true in the gradle.properties file to run annotation processing in a separate task and make compilation incremental.

Task :react-native-google-signin:compileDebugJavaWithJavac
Note: C:\test\jitsi-meet\node_modules\react-native-google-signin\android\src\main\java\co\apptailor\googlesignin\RNGoogleSigninModule.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

Task :react-native-sound:compileDebugJavaWithJavac
Note: C:\test\jitsi-meet\node_modules\react-native-sound\android\src\main\java\com\zmxv\RNSound\RNSoundModule.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

Task :react-native-webrtc:compileDebugJavaWithJavac
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: C:\test\jitsi-meet\node_modules\react-native-webrtc\android\src\main\java\com\oney\WebRTCModule\PeerConnectionObserver.java uses unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.

Task :sdk:compileDebugJavaWithJavac
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

Task :app:compileDebugJavaWithJavac
Gradle may disable incremental compilation as the following annotation processors are not incremental: compiler-4.7.1.jar (com.github.bumptech.glide:compiler:4.7.1).
Consider setting the experimental feature flag android.enableSeparateAnnotationProcessing=true in the gradle.properties file to run annotation processing in a separate task and make compilation incremental.
Note: [1] Wrote GeneratedAppGlideModule with:

Task :app:runDebugReactPackager FAILED
Starting the React packager…

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:app:runDebugReactPackager’.

A problem occurred starting process ‘command ‘scripts/run-packager.sh’’

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.
See https://docs.gradle.org/4.10.1/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 1m 5s
172 actionable tasks: 172 executed
error Could not install the app on the device, read the error above for details.
Make sure you have an Android emulator running or a device connected and have
set up your Android development environment:
https://facebook.github.io/react-native/docs/getting-started.html
error Command failed: gradlew.bat app:installDebug

Can you help me please ?
Thanks in advance :smiley:

@saghul Can you help me please ?

You are running on Windows, right? We don’t support that. You need to use macOS or Linux to build it.

Yes, I just saw that in run-packager.sh :sweat_smile:
I will try with an Ubuntu VM
Thanks for you help