Jitsi-meet-prosody problem after update

Hello everyone.
I’m new to the forum and have a problem.
I installed jitsi-meet as described in the article How To Install Jitsi Meet on Ubuntu 22.04 | DigitalOcean and everything worked without problems for one month.
A couple of days ago i decided to do an upgrade and got this error…

sudo apt upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages were automatically installed and are no longer required:
linux-headers-5.4.0-121 linux-headers-5.4.0-121-generic linux-image-5.4.0-121-generic linux-modules-5.4.0-121-generic
linux-modules-extra-5.4.0-121-generic
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up jitsi-meet-prosody (1.0.6380-1) …
The given hostname does not exist in the config
Component “focus.xxxxx.xxxxx.xx” “client_proxy”
modulemanager error Unable to load module ‘roster_command’: /usr/lib/prosody/modules/mod_roster_command.lua: No such file or directory
Failed to load module ‘roster_command’: /usr/lib/prosody/modules/mod_roster_command.lua: No such file or directory
dpkg: error processing package jitsi-meet-prosody (–configure):
installed jitsi-meet-prosody package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of jitsi-meet-turnserver:
jitsi-meet-turnserver depends on jitsi-meet-prosody; however:
Package jitsi-meet-prosody is not configured yet.

dpkg: error processing package jitsi-meet-turnserver (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of jitsi-meet:
jitsi-meet depends on jitsi-meet-prosody (= 1.0.6380-1); however:
Package jitsi-meet-prosody is not configured yet.

dpkg: error processing package jitsi-meet (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
jitsi-meet-prosody
jitsi-meet-turnserver
jitsi-meet
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can’t find a solution anywhere.
Please advise how to solve this problem.

Thank you all in advance.

What prosody version do you have?

Hi saghul,
thanks for your quick respons.

iF jitsi-meet-prosody 1.0.6380-1 all Prosody configuration for Jitsi Meet
rc prosody 0.12.1-1~focal1 amd64 Lightweight Jabber/XMPP server
ii prosody-0.11 1nightly143-1~focal amd64 Lightweight Jabber/XMPP server

…for information:
~$ dpkg -l |grep jitsi
iU jitsi-meet 2.0.7577-1 all WebRTC JavaScript video conferences
iF jitsi-meet-prosody 1.0.6380-1 all Prosody configuration for Jitsi Meet
iU jitsi-meet-turnserver 1.0.6380-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.6380-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.6380-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.2-18-gade06bf8-1 all WebRTC compatible Selective Forwarding Unit (SFU)

This looks sus. Can you upgrade to Prosody 0.12?

Hi all.
This error seems to have been resolved for me:
cp /usr/share/jitsi-meet/prosody-plugins/mod_roster_command.lua /usr/lib/prosody/modules/

But after:
~$ sudo systemctl restart {prosody,jicofo,jitsi-videobridge2,nginx}
video and sound don’t work… :frowning:

Most probably you don’t have this prosody config in your configuration

Thanks damencho.
How can i upgrade prosody 0.11.4-1 to 0.12.1-1 ?

Listing… Done
prosody/unknown 0.12.1-1~jammy1 amd64 [upgradable from: 0.11.4-1]
prosody/unknown 0.12.1-1~focal1 amd64
prosody/focal,now 0.11.4-1 amd64 [installed,upgradable to: 0.12.1-1~jammy1]

Thanks,
step 4:
~$ sudo apt-get install prosody
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
prosody : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.9 is to be installed
Depends: libicu70 (>= 70.1-1~) but it is not installable
Depends: libssl3 (>= 3.0.0~~alpha1) but it is not installable
Recommends: lua-readline but it is not installable
Recommends: lua-unbound but it is not installable
Recommends: luarocks but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Did you run apt update first?

Yes, i did.

What ubuntu version are you running, focal or jammy? You seem to have a conflicting mix.

Sorry for the delay,

~$ lsb_release -a

Distributor ID: Ubuntu
Description: Ubuntu 20.04.4 LTS
Release: 20.04
Codename: focal

Now I was able to reboot the server.
~$ sudo apt update

Fetched 6,323 kB in 2s (2,879 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
1 package can be upgraded. Run ‘apt list --upgradable’ to see it.

~$ sudo apt upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

~$ apt list --upgradable -a
Listing… Done
prosody/unknown 0.12.1-1~jammy1 amd64 [upgradable from: 0.11.4-1]
prosody/unknown 0.12.1-1~focal1 amd64
prosody/focal,now 0.11.4-1 amd64 [installed,upgradable to: 0.12.1-1~jammy1]

But, jitsi-meet is working!
I mean, video and sound.
I’m happy but what to do with the prosody 0.11.4-1 and 0.12.1-1. Is there a conflict?

You seem to have packages from Ubuntu 22.04 (jammy). I think you’d need to clean that up first.

Saghul, thank you.
I will try it.