Jitsi Meet performance on Raspberry Pi Compute Module 3+

I’m trying to use Jitsi Meet on a Raspberry Pi Compute Module 3+ in Chromium. I’m not running anything else except those two. Unfortunately, the performance is miserable. I get 3 fps and a delay of ~5-10 seconds.

I tried setting the config so it uses H264, but that doesn’t really change anything.

What are some things I could do to improve performance?

You need to activate the hardware H264 decoder for chromium

Raspberry Pi 4: Hardware accelerated video decoding (GPU) in Chromium

Thanks. I followed the guide you posted, but now I still have 5fps. So it did go up, but not by much…

What actually helps a lot is reduction of the video resolution. I guess you typically do not need HD for a video-conference…

I am actually struggling with the same problem. I would like to set the video resolution when I start meet.jit.si with an URL option: URL options to reduce CPU load

So if you find a solution, please share it!

You can change the send resolution by appending the following to the meeting URL - #config.constraints.video.width.ideal=320&config.constraints.video.height.ideal=180.

Thanks jallamsetty,
the “.ideal” commands do the trick!