Jitsi-meet on Ubuntu 16.04 server

I cannot install Jitsi-meet on Ubuntu 16.04 server.
My assumption is because of kernel version.
uname -a returns me
Linux hostname 2.6.32-042stab142.1
Please anyone help me!!! I already spent so much time but still no results.
I successfully installed jitse-meet on other machines guided by official installation document.
here is installation log:

W: /usr/share/ca-certificates/mozilla/TUBITAK_Kamu_SM_SSL_Kok_Sertifikasi_-_Surum_1.crt not found, but listed in /etc/ca-certificates.conf.                                     
WARNING: dhparam1024.pem does not contain a certificate or CRL: skipping                                                                                                        
WARNING: dhparam2048.pem does not contain a certificate or CRL: skipping                                                                                                        
WARNING: dhparam4096.pem does not contain a certificate or CRL: skipping                                                                                                        
1 added, 0 removed; done.                                                                                                                                                       
Running hooks in /etc/ca-certificates/update.d...                                                                                                                               
                                                                                                                                                                                
Adding debian:auth.meet.myhost.online.pem                                                                                                                                  
done.                                                                                                                                                                           
done.                                                                                                                                                                           
dpkg: dependency problems prevent configuration of jitsi-meet:                                                                                                                  
 jitsi-meet depends on jitsi-meet-web-config (= 1.0.3992-1); however:                                                                                                           
  Package jitsi-meet-web-config is not configured yet.                                                                                                                          
                                                                                                                                                                                
dpkg: error processing package jitsi-meet (--configure):                                                                                                                        
 dependency problems - leaving unconfigured                                                                                                                                     
Setting up libevent-2.0-5:amd64 (2.0.21-stable-2ubuntu0.16.04.1) ...                                                                                                            
Setting up lua-event:amd64 (0.4.3-2) ...                                                                                                                                        
Processing triggers for systemd (229-4ubuntu21.27) ...                                                                                                                          
Processing triggers for ureadahead (0.100.0-19.1) ...                                                                                                                           
Processing triggers for libc-bin (2.23-0ubuntu11) ...                                                                                                                           
Errors were encountered while processing:                                                                                                                                       
 jitsi-meet-web-config                                                                                                                                                          
 jitsi-meet                                                                                                                                                                     
E: Sub-process /usr/bin/dpkg returned an error code (1)

Still hope for some help!
-Alex

uh ? I have a jitsi-meet instance running in a 18.04 LXD container under an host running ubuntu 16.04.6 LTS and kernel version is 4.4 ! I have trouble believing that Ubuntu 16.04 could use a 2.6 kernel even for the very first version. What says cat /etc/lsb-release ?

Thank you for reply.
It says:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION=“Ubuntu 16.04.6 LTS”

Hi @AlBog ,

Purposely I made a test for you on how to setup jitsi-meet on Ubuntu 14.04.
Please follow this tutorial :

  1. https://www.vultr.com/docs/how-to-install-jitsi-meet-on-ubuntu-18-04-lts (Even it is written for 18.04 but I tested on 16.04 works well)
  2. If you encounter error on : “Unable to find deploy-hook command /etc/letsencrypt/renewal-hooks/deploy/0000-coturn-certbot-deploy.sh in the PATH”
    Please check this link and follow : Lets Encrypt Problem
    nano /etc/letsencrypt/renewal-hooks/deploy/0000-coturn-certbot-deploy.sh
    Add : #!/bin/bash
    ctrl+x to save and exit
    Then : chmod +x 0000-coturn-certbot-deploy.sh
  3. Continue the step where you had the error : sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

Have fun with Jitsi !!

Sincerely,
arivonto
https://www.linkedin.com/in/arivonto/

My bad, I didn’t mention: I install jitsi-meet on VPS.

Hey if you dont mind try and use our tutorial on how to setup jitsi on ubuntu VPS

1 Like

that’s why you have a so ancient Linux kernel. 2.6 is nearly the kernel of Ubuntu 11 Maybe it would be better to try something newer.

@iongraphix ,

Great Tutorial indeed !

Thank you and sincerely,
arivonto

Give us a star on Github please. Thanks in advance!

1 Like

@iongraphix done ! :slight_smile:

Thanks a million

1 Like