Jitsi-Meet not working when connecting from local network

I have Jitsi-Meet running on a local server. I forwarded the ports through my Internet router, setup a public DNS record (webcam.mysite.com) to my routers static IP address and setup Jitsi-Meet using this public website.

Now everything works if I’m connecting from the outside to webcam.mysite.com

However, If I try to join a meeting from within the local network, it does not work. The site loads (I do see the screen where cached meetings appear), but when trying to open a new meeting for example, I just hang on an empty screen and I’m never prompted to input username and password

I have a similar issue, although I have not tried it from outside.

But I have two setup. One runs in AWS and another on local.

The AWS one works just fine, with web and mobile both. But the local one crashes as soon as we join from the android app.

same problem here.
jitsi accessible from localhost and from outside but not form local lan
our jitsi server is in the dmz using a public ip. lan and dmz are fysically seperated from our firewall.
but ssh, http and https is working form the lan. but nothing to see except the word welcome.

does the url need some extension or something like that?

Hi,
I found it an dns problem. our lan is a windows directory where dns is provided by the AD servers.
the record for the local server was made in the AD before it was published to all open dns servers.
after doing some digging dns all was ok and a browser cache refresh did the rest. all works well right now.