Jitsi-meet Nginx

After numerous installs and uninstallations of apache2 in ubuntu18.04.The problem persists I am not getting nginx proxy, web server on the browser instead I am getting apache2 “it works screen”.

Can you tell me why this is not allowing me to get to the conference like I did when I used jetty.

To confirm the problem, so you laready install the jitsi-meet but after installation you get that screen when navigate to your website?

If that is the problem, try to force using https by typing https://yoursite.com. because sometime the redirect is not working.

Huh… I did all that… I did it one more time. Is it redirect on the server? And why is that ? Is there anything else need to configure thanks.

can you check sudo netstat -ntplu on your server and see what service is listening on 80 & 443?

I see nothing there on 80 but not 443 from nginx.

maybe it is conflict with the videobridge. to test my hypothesis, can you first stop the jvb service for a while and then restart the nginx. and then see if the nginx listen to the 443.

I am still new with Jitsi I am not sure of jvb JITSI SERVER BUNDLE.
I dont see it when I run netstat. Does it go by another name?

you can start/stop the jvb service by using:
/ect/init.d/jitsi-videobridge start/stop
or
/ect/init.d/jitsi-videobridge2 start/stop
depending the jvb version.

jvb will show only ‘java’ when you netstat

Three java services please confirm if these are right. However they are not running 80 or 443.

nginx seem ok now…

However the site is not working: Apache2 is gone because I stopped jvb.

I restart jvb with the result above.

Do you need both nginx and apache2 installed?

If you can, it might be easier to purge both, then update packages in apt, then install jitsi-meet.

Huh … Interesting question. Is that possible I will like to explore that option. My only question is which one will listen to 443 (https) and which will then answer to 80 (http). I like the idea but I lack the flow of the whole process. I was only planning to get nginx to do the work. In this case nginx works but I can get to use jitsi-meet as you can see. Thanks.

If you run

netstat -lu

That will tell you which process is bound to which port:

image

Is this what you expected…?

Almost, but it’s missing the process name.

Try

netstat -tulpn

THE END…

Hey I got this just now I did restart apache2 now I have nginx and apache2 installed. Hhowever, nginx is the one running as active. It must be using port as listener. Take a look as result apache2 cannot be started.

This is the final out on the browser…

Which direction to go now? IDK

Are you in a position where you can start from scratch, and avoid installing apache?

If so, that’s probably the fastest way to fix it.

Otherwise

  • use netstat to check that nginx is binding 80 and 443
  • check your nginx config: does it have anything to do with jitsi in it?

Yes I will do as you said then I will save headaches. Apache is using the cert files -> 443
nginx on 80. I switched things around. The fact both nginx and apache2 are actually running now.

I uninstalled the who jitsi-meet.

I will say lets just work with apache for both 80 and 443. I will say remove nginx.