Jitsi-meet mobile not working

Hi,

I’m trying to use jitsi-meet mobile for many days, but that’s not working anymore…
I installed a backup from April 25th 2019, that’s also not working anymore. At that moment, it’s sure jitsi-meet mobile was correctly working because I was using mobile application for tests.

Do you know where does the issue come from ?
@saghul @damencho

Thank you,
Yann

Which version of the mobile App are you testing with, what is the error you see?

Version 19.1.0 build 791798.

“You have been disconnected. Please check your network connection.”

Jitsi-meet web and electron are working normally.

I have also issue with Jisti meet on Androïd since yesterday. Web and desktop are OK, but can’t create / enter room on Androïd…
I have the message “call aborted - There’s already another call in progress. Please end it first and try again”.
Tried to restart all jitsi, did also a “make”, but nothing change…

We haven’t made a new release since about a month.

I just tested the store version against meet.jit.si and got no problems. Are you using your own deployment? Does it work with meet.jit.si ?

@ziloub This is typically a problem with some Android implementations of ConnectionService. Can you try to restart your device and try again please?

It works perfectly with “meet.jit.si”, and absolutely not with my own deployment. What is strange is that it works with all other clients (Electron, Meet, etc.).

@Yann Are you using a self-signed certificate by any chance? If not, is the full chain present on the web server?

I’m using Let’s Encrypt as SSL certificate. After jitsi-meet installation, I just executed “letsencrypt.sh”. But SSL certificate is currently working and nothing really changed since Thursday 25th 2019 (it was working).

Can you share (msg me privately if you prefer) your deployment URL?

Hi @saghul, thanks for your reply.
I tried everything :

  • force the application to end
  • restart my mobile
  • uninstall / install the app
    sometimes, for like few minutes, it is working. But everytime, the error appear again with same message…
    Also, I noticed that when i do a “normal call” with my phone, it says : “this will end your call on the application” (like the Jitsi Mobile app keep working like there is a call, when there is no call at all…)

I really don’t know what happends. Tried everything, but same everytime :confused:

@ziloub That’s unfortunate, sorry. What device and Android version do you have?

Huawei P10 with Androïd 8.0.0

Just to add : it was working fine before, but since like 3 days, we always have that problem (without any changes on our mobile. Same version of Androïd, and nothing changed… really weird).
Seems like something changed, as @Yann seems like have problems too since the same time, without changes also.

@ziloub Can you share your deployment URL? @Yann 's problem was related to the webserver being really slow, as the mobile app aborts the join instead of waiting forever.

@saghul, i just sent you private message with URL of our web application and also the name of our app for Androïd on the Play Store :slight_smile:

Hi @saghul, I also getting the “call aborted …” message, in my case I found this issue in a Moto G5 and Huawei P10 devices. I’ve try restarting but I’m still having the same behavior. Do you have any other recommendations in order to solve this?

We have a fix inplace that should help, will be part of the next release. Until then, if you can build the app from source and give it a shot, that would be great.

Thanks! I will give it a try.

I have also the Huawei P10, and have same problem. So seems like there is an issue with Huawei.
Could you please give us an approximately date for the next “release” of the Jitsi Androïd application, to resolve that issue ?
Thanks ! :slight_smile: