Jitsi-meet installed on Ubuntu 18.04, nginx port 8443 - connectivity issues

Hi,

for some internal reason I had to configure NGINX to be sensitive on port 8443 instead of 443. All fine so far, installation good, jitsi-meet is running. I can open it in my browser (you should be able too)

https://jitsi-meet.ddns.net:8443/

Except…

POST requests are leaving my browser towards port 443, which will not work obvioulsy…

strophe.umd.js:5123 POST https://jitsi-meet.ddns.net/http-bind?room=legendaryadultsavoidsecondly net::ERR_CERT_COMMON_NAME_INVALID

I would consider this to be a bug. Any chance to get that changed or fixed?

TIA

The certificate doesn’t contain this domain

Hmm. The certificate is from Let’s encrypt and if I reconfigure NGINX to use port 443 everything works.

I’m not seeing a problem with the certificate

My point is: The server is running at 8443. And I can open it in the browser (maybe you have tried 443? This is another server on another machine in a DMZ behind a DSL router)

What I see is that the website loads well, but the POST bind request is not going to port 8443, but 443 instead, which is not working. It seems to be a misconfiguration in the way POST determines the host (?)

I didn’t try it but probably you need to change the bosh url in your /etc/jitsi/meet/jitsi.yourdomain.com-config.js file too. Add the port…

Almost, but there is still an error (please check by yourself):

Host config looks like so right now:

There must be still something…

I don’t think the following will solve the issue but it seems needed

/etc/jitsi/videobridge/jvb.conf

videobridge {
    ...
    ...
    websockets {
        domain = "jitsi.yourdomain.com:8443"

No unfortunately no change. The error remains, connection cannot be established, retry

Did you restart the videobridge service?
It works for me

How did you do that? I restarted the entire box

The changes

  • listen port in Nginx config

  • adding port to the bosh URL in Jitsi Meet config.js

  • adding port to domain in /etc/jitsi/videobridge/jvb.conf

  • restarting jitsi-videobridge2

systemctl restart jitsi-videobridge2.service

Ok. Will check this later and report. Thanks so far

Yepp. Confirmed. That works.

In contrary to what I have changed earlier in config.js I have now let domain, muc and all commented settings as-is, just changed bosh as you said.

Any idea why I do not have to adapt all? I mean domain might be obvious…

Anyway, seems to work now. Thanks for your assistance.

Regards

XMPP domain isn’t used for https. It has its own port.