Jitsi-Meet: Increase channel limit

I have wide channel, but when I start client (electron app) the traffic doesn’t exceed 250Kb/s. I have 2Mb/s available. I increased maxBitratesVideo options, but this didn’t help. When the picture is static it’s quite enough, but when screen changes jitsi make quality low to provide acceptable 20-30fps and stays below 250Kb/s anyway. How to increase this limit?

Also could anyone point me where is the documentation or any description on this https://beta.meet.jit.si/config.js. Every link that I found either outdated or points here https://jitsi.github.io/handbook/docs/dev-guide/dev-guide-iframe.

Settings I use are

function createVideoTrack() {
    JitsiMeetJS.createLocalTracks({
        devices: ['video'],
        resolution: 1080,
        minFps: 15,
        maxFps: 30,
        constraints: {
            video: {
                aspectRatio: 16 / 10,
                width: {
                    ideal: 1440,
                    max: 1440,
                    min: 1440
                },
                height: {
                    ideal: 900,
                    max: 900,
                    min: 900
                }
            }
        },
        cameraDeviceId: $('#video-device').val(),
        
        enableP2P: true, // flag to control P2P connections
        // New P2P options
        p2p: {
            enabled: true,
            preferH264: true,
            disableH264: true,
            useStunTurn: true // use XEP-0215 to fetch STUN and TURN servers for the P2P connection
        },            
        
        useStunTurn: true, // use XEP-0215 to fetch TURN servers for the JVB connection
        useTurnUdp: true,
        bosh: '//beta.meet.jit.si/http-bind', // FIXME: use xep-0156 for that
        websocket: 'wss://beta.meet.jit.si/xmpp-websocket', // FIXME: use xep-0156 for that

        videoQuality: {
            maxBitratesVideo: {
                low: 2000000,
                standard: 5000000,
                high: 15000000
            }
        }
    }).then(tracks => {
        console.log('Tracks created: ', tracks);
            localTracks = tracks;
            tracks[0].attach($('#local-video')[0]);
            room.addTrack(tracks[0]);
        }).catch(error => console.log(error));
}
1 Like

@4xy Would suggest you send your complaint to the support team as well as seek clarifications on what the beta can handle.