Jitsi meet in flutter not working on android 12

I have integrated jitsi_flutter for group call. But, the app is not installed in the latest android supported version 12.

Here is the link for jitsi_flutter, which I have used. https://github.com/gunschu/jitsi_meetweave-hair

I am getting this issue when try to run app in android 12 supported device.

adb: failed to install E:\Flutter\flutter_jitsi\build\app\outputs\flutter-apk\app.apk: Failure [INSTALL_PARSE_FAILED_MANIFEST_MALFORMED: Failed parse during installPackageLI: /data/app/vmdl502165721.tmp/base.apk (at Binary XML file line #110): org.jitsi.meet.sdk.ConnectionService: Targeting S+ (version 31 and above) requires that an explicit value for android:exported be defined when intent filters are present] Error launching application on sdk gphone64 x86 64.

Well your problem is really with android not jitsi nor Flutter and if u google your error “ INSTALL_PARSE_FAILED_MANIFEST_MALFORMED you Will see its a config issue only

Regards

Ask the FLutter plugin authors to update the Jitsi Meet SDK to the latest.