Jitsi Meet (Electron) not working since latest update

Hi,

We use the Jitsi Meet Electron app for daily staff meetings. Since the most recent update (Version 2.4.0) it no longer seems to work.

Someone can create the room, but no one can hear each other and most can hear the e2ee noise even when the e2ee encryption is enabled (there is no difference whether e2ee is enabled or not; the sound remains garbled).

It has been like this every singe day since the upgrade.

Any ideas how this can be solved?

Thanks

I cannot reproduce this. What platform are you using and what deplyment are you using, meet.jit.si or your own?

Thanks.

There are 10 people on the call. We all use Windows 10.

We use the meet.jit.si servers

If nobody toggles e2ee, does the problem still occur?

I am not sure.

We had to toggle the e2ee under version 2.3.1 it it worked fine. the problem only started when we switched to version 2.4.0.

I know people tried toggling the e2ee buttom as they tried to talk. That diud not work (e.g. for myself: the sound remained garbled whether I have enabled the e2ee or not). I am not sure whether there was ever a moment that all 10 of us had e2ee disabled at the same time.

FYI:
I just (10 min ago) uninstalled Jitsi Meet 2.4.0 and re-installed version 2.3.1. and I asked 3 other colleagues to do the same and then we had a call. Everything worked fine. (with e2ee enabled).

One of my colleagues confessed though that he had not yet installed version 2.4.0 (so in the last 3 days when it did not work, apparently some of us were using version 2.4.0 and some of us were using version 2.3.1). I am not sure whether that could be a problem?

<< If nobody toggles e2ee, does the problem still occur? >>

The way we do it is that the host / facilitator turns on the e2ee (and sets the password) before (s)he sends the link to others to join the meeting.

We have just heard of a potential bug in this exact scenario (toggling e2ee ON before other participants join). We are investigating, but the app version should not matter here, since the e2ee code is the same, since it runs on the iframe.

Nevermind, I think this is it:

CompileError: WebAssembly.instantiate(): Wasm code generation disallowed by embedder

This must have happened when we switched to our new E2EE implementation, which uses some WASM.

Thanks.

I am not sure whether this is relevant:

  1. On the call I did with the 3 colleagues (after we all 4 downgraded to version 2.3.1) a few minutes ago, I had set the e2ee ‘on’ 30 min before the others joined, it worked fine

  2. Also last week (when we were all using v 2.3.1) we always enabled the e2ee before the other 9 would join (and it never was a problem).

Only after we (or now apparently: some of us) upgraded to version 2.4.0 did the problem start (on Monday).

Thanks.

So the solution is to wait for new version of the app?

Possibly. Using it in the browser should be fine though.

Thanks.

I have never been able to make e2ee work in a browser though.

I have tried Chrome and several other Chromium based browsers, but none show the e2ee option in the security menu (only lobby and password).

check:
chrome://flags
and enable the “Experimental Web Platform features”
after restarting the e2ee should work.

I tracked this problem to the Electron 10 upgrade. There is a bug: https://github.com/electron/electron/issues/25127 WASM modules fail to load and the new E2EE uses a WASM module. Oh well, back to Electron 9. 2.4.1 is coming up.

2.4.1 is now released.

1 Like

Thanks a lot!

Thanks Mr Smith!

Thanks Saghul. Much appreciated