Jitsi meet does not work if I am in different network

Hi,

I installed Ubuntu and Jitsi. I have installed all certificates and opened all the ports and jitsi still does not work.

If I am in same network it is working fine. If I have one device on LTE or other wifi network I can see that fellow Jitser has joined, they can type and send emoji but I cant see or hear them. I really tried everything and I cant get it to work.

Any help would be much appreciated.

Best Regards,

Dominik

Are you sure UDP/10000 directed correctly?

1 Like

Thank you for the replay.

I have checked NAT. I redirected 10000/UDP to our server and UFW on server 10000/UDP is allowed.

Am I missing something else?

Does it work when there are 3 participants in the meeting?
Don’t try with 2 participants because P2P is another case.

If participants can see each others (black screen) but cannot get audio/video, this mean that the media channel (JVB connection through UDP/10000) doesn’t work.

  • maybe JVB doesn’t publish the correct IP
  • maybe incoming UDP/10000 traffic is bloked on the server side
  • maybe outgoing UDP/10000 traffic is blocked on the client side

Thank you for the replay.

I tried jitsi meet with 3 people in same network and it does not work. It is working with 2 people in the same network.

I checked the ports and they are open (allowed). On my Ubuntu I also disabled Firewall. Funny thing is that it worked well before. After upgrade (ubuntu/jitsi) it is not working anymore.

Hi,
I found the problem. Now it is working as it should.
Thank you for all your help.
Best Regards,
Dominik

1 Like