Jitsi Meet - displayname via URL param?

Hi Folks,

Amazing project :-). Quick question - I’m using Jitsi Meet, and would like to pass the name of the participant via a URL parameter so that they don’t need to set it themselves. Something like:

meet.jit.si/meeting-refererence?name=Alice

I’ve tried a few obvious parameter names, and taken a bit of a trawl through the code and docs, but can’t find any helpful reference. So - is it possible? Is there some page in the documentation that would list any URL parameters respected by Meet?

Thanks in advance for any assistance :slight_smile:

2 Likes

That is still not possible on meet.jit.si, but that change is coming in few days :slight_smile: When it is deployed this is what the link will look like:
meet.jit.si/meeting-refererence#userInfo.displayName="nwoodhouse"
The quotes are important :slight_smile:

8 Likes

That’s excellent to hear. Perfect.

“Next few days” – really that soon - that’s wonderful :slight_smile:

It would be great if there were a page in the docs somewhere detailing what params are possible to pass.

Stupid question I’m sure - but just want to be sure - but are single quotes just as acceptable?

meet.jit.si/meeting-refererence#userInfo.displayName=“nwoodhouse”
meet.jit.si/meeting-refererence#userInfo.displayName=‘nwoodhouse’

just double.

1 Like

Hi damencho,

Amazing project, love it !
Any news on this feature ?

We will do an update these days

2 Likes

i’m trying to open android jeetsi meet app using an intent
is there any app parameters reference?

var intent = “intent://meet.jit.si/”
+ “soluticaConference99888123#”
+ “jitsi_meet_external_api_id=0”
+ "&userInfo.displayName=“DiegoMobile_R123456"”
+ “&config.disableSimulcast=false”
+ “&config.defaultLanguage=%22es%22”
+ “&config.openBridgeChannel=%22websocket%22”
+ “&interfaceConfig.filmStripOnly=false”

The app is not taking the displayName parameter.

Is there a way to specify a password ?

Thank you

Have you tried to url-encode the double quotes around the display name as %22 as you did for the defaultLanguage param?

that was it. What about the password?

Update done, it works !
Thank you very much :slight_smile:

This is great! However, how can we use this with http URL? I want to enable users joining to pre-set their name so they don’t show up as random users! GET or POST - anything is fine.

Thanks!

@damencho
Is this display user name via URL function implemented?
Request to reply soon.

Is this available on the self-hosted Jitsi Meet version, @damencho ?

Yes

Hello, Where can we get a full list for url params?


But some are not whitelisted. This is the whitelist: https://github.com/jitsi/jitsi-meet/blob/master/react/features/base/config/configWhitelist.js#L11

1 Like

Thanks for your help @damencho, do you know if there is an option to hide microphone or camera button using url params? or prevent users to unmute?

Maybe try editing interface config and remove it from the list of buttons.

Trying to connect to my jitsi server from my mobile flutter app using jitsi_meet_flutter plugin which calls the server like this

.invokeMethod<String>('joinMeeting', <String, dynamic>{
          'room': options.room?.trim(),
          'serverURL': options.serverURL?.trim(),
          'subject': options.subject,
          'token': options.token,
          'audioMuted': options.audioMuted,
          'audioOnly': options.audioOnly,
          'videoMuted': options.videoMuted,
          'userDisplayName': options.userDisplayName,
          'userEmail': options.userEmail,
          'config.defaultLanguage':"ptBR"
        }

The last line 'config.defaultLanguage':"ptBR" was added by me in the hope that would load the ptBR version, but it didn’t (does not throw error either). On the server I already changed the config so it loads ptBR when connecting thru a desktop browser. That works but I needed the mobile client to also show the user interface in porutguese. Help appreciated.