Jitsi-meet displayName from shibboleth headers

I’ve managed to convince jitsi-meet into external auth and for the meantime during test I inject authentication headers in apache using

<Location /login>
RequestHeader set mail "foobar@<domain>"
RequestHeader set displayName "FooBar"
ProxyPass http://localhost:8888/login

I am shortly welcomed as “FooBar” by jicofo external auth servlet, but jitsi-meet doesn’t update my displayName?

I’ve toggled useNicks in jitsi-meeting config, but that doesn’t help. How can I convince jitsi-meeting to consume the freshly acquired displayName from the external authenticated testuser?

I Martin,
The shibboleth displayname is not set into jitsi meet UI variables. I think it could be done by modifying the jicofo shibboleth auth servlet to set the client local storage displayname value to th shibboleth attribute.

Regards Damien.

Hi Damien,

Thx for your answer.
I see that displayName is read in ShibbolethHandler.java in jicofo src:

But it only seems to be used to greet the user? :frowning:

On the other hand, https://rendez-vous.renater.fr/ does use one of the shibboleth attributes to generate displayName from eduGAIN login, so the code is available at Renater? Was this enhancement never merged upstream?

Best regards,

Hi Martin,

Rendez-vous doesn’t use the displayname shibboleth attribute.
It only display the user’s authenticated identity name (email attributes) in the profile menu.
The user profile menu was changed since the Jitsi version 2794 currently used by RENdez-vous.
This login informations is no longer displayed in last stable release that’s why you didn’t see it in your Jitsi-Meet instance.

A made a pull request for jicofo code (https://github.com/jitsi/jicofo/pull/328) to set the localstorage features/base/settings displayName to the shibboleth displayName.
It is set to shibboleth displayName or email if user havn’t already set a value to displayName .

Best Regards,

Hi Damien,

I could have sworn I saw my displayName used in rendex-vouz but I must have been dreaming :wink:
Nevertheless, thx for the pull request. It only seems a logical step to consume the displayName when it’s supplied in the SAML token. Nice!

Hi there,

I’m trying to add Shibboleth as an auth method for a self-hosted Jitsi.
Everything is working as expected so far, however displayName parameter is being ignored and only shown in the redirect step (Hello $displayName).

What would be a good way to make use of displayName and replace Fellow Jitster with it?


Interested in this as well… Has anyone found a solution ?

Hi creativeguitar,
I made a PR some times ago to force displayname to be set by auth attribute (https://github.com/jitsi/jicofo/pull/328).
But it wasn’t approved yet (maybe when @Pawel_Domas find some time).


Thank you Damien! Is there any way to test this in the dockerized version of Jitsi ? I am new to docker and I haven’t found a way to modify java files like the ShibbolethHandler.java file.