Jitsi Meet disconnecting after 10 or so seconds

I’ve installed Jitsi on a few different Ubuntu servers with Nginx. Each time I get the same sort of error in that it disconnects every few seconds when another person is in the room. I’m not sure why and I’ve installed it according to instructions that seem to work for other people. I have the firewall set properly seemingly. I also have my log from jicofo.log. I’m not sure where to go from here, but I’ve done it a few times with new servers and even tried different hosts.

Does anyone have any ideas on that? I’m not behind a NAT or anything, just have a server set up on a cloud provider.
Thanks

What is your js console.

I’m not sure what you’re referring to on the JS console?

Thanks

to open the console on Chrome:

  • mouse right click
  • inspect
  • console tab

Ok. Thanks for letting me know about that in Chrome. It was very handy. I can see a few errors that came up right before it was cut off. Here’s a copy of the log. Thanks so much for helping me troubleshoot this. I’ve just begun messing with jitsi and I really want to be able to create my own working one.

jitsi.log (347 KB)

CONFERENCE FAILED: conference.iceFailed

Follow the quick install guide advanced section, you have a problem with firewall, not forwarded port to jvb or jvb not advertising public address.

hey you are very likely behind NAT

what is your sip.communicator.properties?

@vtaero, Also… check out this post:

So, this is on a random cloud server, it was with AWS lightsail server first. It had the same problems. Now it’s a new installation on Ionos.com. Each has had the same issues. I don’t think it could be a NAT problem because I’m not behind anything but the simple firewalls. On the lightsail server, it was only behind their firewall (not even the linux one) which I had allowed the ports through. Now on ionos.com I thought it only had the UFW firewall but it also has one built in that I just found and so I allowed the same ports on that.

It’s set up with an A record pointed to the IP address. The A record is for a subdomain on my main domain.

In looking at the instructions to check the connectivity from @corby I wasn’t sure how local IP could do anything, so I put in only the command about the public IP and then it worked!

I’m reasonably new to linux and cloud servers. I’ve created a couple websites and a few re-streaming servers on the cloud using nginx. However I’m by no means an expert. I had programing skills back in the 90s but that was on Fortran. For the past 20 years I’ve been an aerospace engineer by trade and learning cloud servers in my spare time. Any help on these things is very much appreciated.

I think I have it working now! Thanks so much for all your help.

Now I want to update the system to make the home screen look a bit different and have organizational graphics. :slight_smile:

Can anyone point me in the right direction for any of that?

Thanks again!

Glad it’s working now. Check out these posts for customization:

And

Search the forum for other ideas. There has been many options discussed.

Hi @emrah
Restart this three services on your linux server
sudo systemctl restart prosody.service
sudo systemctl restart jicofo.service
sudo systemctl restart jitsi-videobridge2.service

Hello,

I have the same problem of disconnecting after few seconds but only for users of one specific internet service provider (we have 3 telecom providers in our Country). The issue isn’t faced by users from the other service providers.

It was working well for everyone for few weeks but since October 1st the problem started with this service provider.

The issue isn’t faced when using meet.jit.si server.

What do you think can be the reason?

Sounds like the affected ISP may be blocking some ports or something. They likely made a change starting October 1st that’s affecting your access. Maybe check with them?

Thank you Freddie for your answer.

That was my conclusion also, but when I contacted them they told me that there was no change from their side.

The question also is why the service is working well with meet.jit.si server and also 8x8 solution? It isn’t the same port which is used?

Oh, so this problem is only on your server?

I thought it was only in my OVH server in France.

So I tried a linode server in different locations Germany and different locations in US but I got the same problem.

The only exception is meet.jit.si and the paid version of 8x8