Jitsi Meet disable TileView

Hello everyone,

so I’ll explain my situation first. I have a JitsiMeetAPI embedded within my page and I want to group my participants together without the TileView (Groups of 4). Since I updated my jitsi instance to the newest Version, it appears to automatically switch to TileView once a 3rd participant joins.
I got two questions:

  1. Is there any way to prevent this (obviously it would be great without recompiling but I know this could be the last option to go for eventually)

  2. I. tried using the API function executeCommand(“toggleTileView”) both in combination with an eventListener and to test it just single handed within my jitsiMeetAPI onload function but apparently it doesn’t seem to work. At least not consistently, I haven’t found a pattern yet on when it’s working and when not. Are there any known issues or restrictions to the function (and or the tileViewChanged eventListener)
    PS: If I try to run the api.executeCommand(“toggleTileView”) from the console comandline, it returns undefined and nothing happens. Running api. executeCommand(“setNickname”) etc. work fine though

Already thanks in advance for a hopefully quick answer, since I need to figure this out rather quick for production purposes.

Greeting,
Jan

I have the same issue with toggleTileView not really working as you’d expect. It would be nice if instead of a “toggle”, it was a true/false. That would allow us to get around this “3rd person joins and tileview is enabled” issue. Every time a participant joins, we could just force toggle it off.

I don’t want to disable it completely as the 3rd+ participants that join will want tileview on. But the original two that are in the meeting are the ones talking and the 3rd+ participants are just observers.

Tile view is not enabled when there are 2 participants in the call, it is turned on after the third one joins.

Yes, enabling it when a 3rd joins would be just fine, but it is being forced on for all participants. I want my participants to NOT be forced in to tile view and just have the option to turn it on themselves or for me to do it via api.

So that is how it works today, if enabled it turns on for everyone after the 3rd joins

Try disabling it in the config and then use the api to toggle it IFrame API · Jitsi Meet Handbook

Ah, I will give that a try and get back to you, thank you.

Is there an override for this in the iframe api? When I try to set this flag, it doesn’t seem to do anything.

Hum, it is whitelisted so it should be fine

I’m setting it here in options:

configOverwrite: { disableTileView: true }

Is that the correct spot?

Yep. You can open the console and change to the iframe and print variable config to see is it set there, to double check …

I can see it in the iframe that we are passing it along with our other override variables if that is what you mean.

I’m saying that you can check in the js console did that got a reflected in jitsi-meet config:


You just need to make sure you are in the correct iframe (I’m directly on meet.jit.si so my location is top on the screenshot).

I just tested it on meet.jit.si and it works by passing it as url param which is equivalent of the configOverwrite:

Is your deployment up to date?

Yeah, we’re sending it and it shows up in the iframe data being sent, but it is not being extended according to the JS console. I’m guessing this is something that was added within the last 1-2 months? I believe we are running a version from end of November 2020.

Oh, yep. Maybe that is the case.

Okay, I’ll leave my changes in and check them the next time we do a software update. Thanks for your help!