[Jitsi-Meet Dev] How to changing the URL in Setting

I try to find them but cannot found . I had clone a gibhub Thank you.

I’m not sure I understand. You are trying to change the URL in what settings? Is this in the mobile applications? If you want to change the default, you can specify it with a prop to the root component when loading a URL. Is this what you need?

Thank you for your suggestions I’m trying change this.

Server URL placeholder

today update my jitsi meet app in my cell phone (android)
but when I go to setting and profile section, Display name show me “Display” and Email show me “Ema”
is this a bug?

1 Like

Ah, I see. You can modify it here: https://github.com/jitsi/jitsi-meet/blob/master/react/features/app/components/AbstractApp.js#L33

We are not aware of this happening. Can you please open an issue?

I have same issue …

@kuntalparbat What issue exactly?

I was unable to remove the default url from settings of jitsi-app.

I have change default url before making SDK and now it working on my custom build app.
Thanks.

Ah that. If you are using the SDK, there is now a way to change the default URL without the need to build it yourself. See some example projects here: https://github.com/jitsi/jitsi-meet-sdk-samples/search?q=serverurl&unscoped_q=serverurl

Is there a way to set the default serverURL in the Jitsi app without doing it manually?

I figured out that a URL call like

http://conf.myserver.com/mymeeting?config.externalConnectUrl=conf.myserver.com

overrides the server setting (i.e. meet.jit.si) for a particular conference, but I would like it to also set it my server as the default for my community.

Is there a way?

Thx, Cal

have you got the solution for this???

No, you can either set it manually in the settings and it will be the default thereforth, or build the app yourself to use your own server by default.

Not finding where to set the default in the app. Searched and replaced ever instance in the code for meet.jit.si, and still the testflight app seem to think the default is meet.jit.si. Wondering if this setting being set from the server and not in the code.

Thx, Cal

This doesn’t seem to work for me when using the Android SDK version 2.5.1.
My situation seem similar to @Cal_Thixton
Regardless of whether I use the following options:

JitsiMeetConferenceOptions options
                = new JitsiMeetConferenceOptions.Builder()
                .setWelcomePageEnabled(true)
                .setServerURL(ourServerUrl)
                .build();

or these

JitsiMeetConferenceOptions options
        = new JitsiMeetConferenceOptions.Builder()
        .setWelcomePageEnabled(true)
        .build();

…the app is always loading meet.jit.si and also the settings page shows meet.jit.si.
I am however able to open a specific room on our server like:

JitsiMeetConferenceOptions options
                = new JitsiMeetConferenceOptions.Builder()
                .setRoom(ourServerRoomUrl)
                .build();

Is there any way to make the Android SDK default to our server url instead of meet.jit.si?

Is there any way to set Server URL by end user by self. Application should verify the URL and set as default server URL.