Jitsi meet authentication with mod_auth_custom_http on prosody

Hi @damencho,
im trying to config authentication with mod_auth_custom_http on prosody.
help me config jitsi meet system to do that.

Thanks,

Use this guide: https://github.com/jitsi/jicofo#secure-domain and instead of
authentication = "internal_plain" use authentication = "custom_http", and also the creation of the users will not be using prosodyctl register ....

Hi @damecho,
I configed prosody config and jicofo but it didnt work, and my authentication server didnt recieve request authentication from meeting.
Pls review view it. Thanks.
This’s my prosody config:

-------------------prosody config-----------------------------------------------------------

VirtualHost “mydomain”
authentication = “custom_http”
auth_custom_http = {
post_url = “http://35.a.b.240:3000/checkUserinCore”;
}

    ssl = {
            key = "/etc/prosody/certs/mydomain.key";
            certificate = "/etc/prosody/certs/mydomain.crt";
    }
    -- we need bosh
    modules_enabled = {
        "bosh";
        "pubsub";
        "saslauth";
        "ping"; -- Enable mod_ping
    }
    c2s_require_encryption = false

Component “conference.mydomain” “muc”

modules_enabled = {“muc_max_occupants”}

admins = { “focus@auth.mydomain” }

Component “jitsi-videobridge.mydomain”
component_secret = “J1RltejO”

VirtualHost “auth.mydomain”
ssl = {
key = “/etc/prosody/certs/auth.mydomain.key”;
certificate = “/etc/prosody/certs/auth.mydomain.crt”;
}
authentication = “internal_hashed”

Component “focus.mydomain”
component_secret = “D5zq#z6c”

VirtualHost “guest.mydomain”
authentication = “anonymous”
c2s_require_encryption = false


-----------------------jicofo sip-communication config-------------------------------

org.jitsi.jicofo.ALWAYS_TRUST_MODE_ENABLED=true
org.jitsi.jicofo.auth.URL=XMPP:mydomain


image

Check prosody for errors.