Jitsi Meet App for Android not working for own server - Bug?

Hi, when I use Jitsi Meet App for Android with the Default-Server https://meet.jit.si/ everything works fine.

But when I use a own server such as meet.myserver.com then I couldn’t get a connection. It seems that internally only meet.jit.si/ will be used. No override is possible.

1 Like

As far as I know the app works only with real certificates and doesn’t work with self-signed

Also the cert must be one with full chain.

I always use a own server with a real certificate. The Server is reachable by browser.
I use the last Version V20.2.2 build 4116609 (21.04.2020) for Android on my mobile. Under configuration I’ve set my own server-URL. After this I’ve got no connection to my server. But it works only for https://meet.jit.si

I am having the same problem using a local Certificate Authority and a full-chain certificate on the server. The app works fine on IOS and all browsers (even on the Android phone), but the android app on the phone does not work. The same version of the Android app on my tablet (Android 5) works fine. There is something peculiar to the app on Android 7 that makes it not work.

same problem… iPhone, new Edge and Chrome works fine. Only android app is not working. Using Let’s Encrypt Certificate. Chrome browser says “Certificate Valid”
image

I’m having a similar issue. I have installed the docker Jitsi meet server and I’m able to connect through web browsers with no problem. I can connect using the mobile client on Android 8, but I’ve tried 3 different devices with Android 7 and it won’t work, even though it works fine in the mobile web browser in desktop mode. I get an error in the Jitsi client saying:

You have been disconnected. You may want to check your network connection. Reconnecting in xx sec…

I’m using 20.2.3 build 202030.
I’ve checked my Let’s Encrypt certificate at https://whatsmychaincert.com and it is successful.
I also tried updating my web/config.js BOSH url to the full address instead of relative, but no change.

There is a similar post at https://community.jitsi.org/t/android-7-clients-disconnected/34182

3 Likes

I was also facing same issue even when using purchased signed certifcate.
As per the reply from Jeff.Bigler, I tested my site on https://whatsmychaincert.com and it failed. But it also provided me a new chained certificate.

I used that chained cert instead of Previous one, and meet started working from Jitsi app.

Thanks to Jeff.Bigler.

I also faced the same issue and fixed it as following as:

a) Open “/etc/jitsi/videobridge/sip-communicator.properties”
b) Add “org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true”

After rebooted, it works well